Download

Material Issue / Bug - Used With Static Lighting (Will not stay unchecked)

Pretty much what the title of the thread says. I made a new material and when I try to turn off “-Used With Static Lighting” and then hit apply or save it, it just reverts back to being checked again. My material is Emissive Unlit. I would like to be able to turn this option off because I don’t want this particular material lighting my scene at all, I just want it to show up for scenery purposes. I’m guessing this is just a bug but any info is much appreciated.

-Thanks, RCM.

I’m assuming it’s because it is unlit?

The Editor sets these switches automatically, they are in this way such more informative to you than a setting. YOu can enable stuff here when you create a Material to spare yourself recompiles.

But if you successfully disable this use checkbox and the Engine uses a mesh with this material for static lighting, thus those things don’t agree anymore, the part of the mesh will then be drawn with the engine default material instead of yours.