Material editor does not open, Static mesh editor does not open

Hello!
So this is very disturbing, i am working with UE more than a year now, and i never faced such a bug before.
A week ago my unreal went mad, and stopped to open the static mesh editor… It gets stuck like in the linked image (see it below)…
I am using Nvidia GTX Titan X
Intel i7 5960X cpu
32 GB ram
Windows 7
I tried to uninstall and reinstall unreal… It worked for 5 mins then it stopped to work again.
Any ideas why this can be?
btw. If i build the project from the github branch it works fine, but unfurtonately i cannot go with the github branch forever, becouse of many reasons(some cutom plugins etc… )
Best regards
Előd S.

Hey elodakielod,

Try going into the ‘Window’ menu in the editor and selecting the ‘Reset Layout’ to see if that fixes the issue.

This seems like a very specific issue to your project or engine version. Can you reproduce this issue in a blank project created from the launcher?

Thanks,

Andrew Hurley

Hey!
Thx for the fast answer. So first i crated a blank project, and it didnt work, but then i was using the reset layout as you suggested. It works now!
Thank you! What could have caused this issue out of the sudden? :slight_smile:
I hope it wont come back, if it does im keeping you updated about it.
This was a good ending for my workday! thx :smiley:

Sometimes simply re-arranging windows and accidentally closing them can happen. This is why we have the reset layout option just in case you cannot open or locate your windows. I am glad you were able to get your project back up and running as expected :slight_smile:

Cheers,

Andrew H

This solved my problem :slight_smile: Thank you!!!

Thank u!!!

Thanksssss was happening also with me, and reset just magically fixed it!! :slight_smile:

cheers same thing happened to me and could not open or edit a material resetting the layout in UE5 did the trick