Material editor crash and simulate/play not working

Hello guys,

still newbie and not sure if I’m posting in the right place.

I have installed UE 5.1 days ago and found out eveyrtime I open the material editor it crashes.

here’s the crash report : LoginId:bc4a6d0e41b879cfd08de9a424099c5c
EpicAccountId:19c7043c7d9b4fb8a5e08762a059bb03

Assertion failed: (Parameters.DestClass->GetPropertiesSize() >= Parameters.SourceObject->GetClass()->GetPropertiesSize()) [File:D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 2756] Source and destination class sizes differ. Source: Material (2848) Destination: PreviewMaterial (2840)

UnrealEditor_CoreUObject
UnrealEditor_CoreUObject
UnrealEditor_MaterialEditor
UnrealEditor_MaterialEditor
UnrealEditor_AssetTools
UnrealEditor_GLTFExporter
UnrealEditor_UnrealEd
UnrealEditor_UnrealEd
UnrealEditor_UnrealEd
UnrealEditor_ContentBrowserAssetDataSource
UnrealEditor_ContentBrowserAssetDataSource
UnrealEditor_ContentBrowserAssetDataSource
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_ContentBrowser
UnrealEditor_Slate
UnrealEditor_Slate
UnrealEditor_Slate
UnrealEditor_Slate
UnrealEditor_ApplicationCore
UnrealEditor_ApplicationCore
UnrealEditor_ApplicationCore
UnrealEditor_ApplicationCore
user32
user32
InkObj
atlthunk
user32
user32
UnrealEditor_ApplicationCore
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
UnrealEditor
kernel32
ntdll

only thing I modified was installing Luo’s GPU lightmass to use it instead of using Epic’s plugin

aside of that , I created and downloaded as well a “follow spline BP” to test it on cars or any actors, I tried every tutorial but nothing happens when I press play or simulate.

Any help would be appreciated, the reason I put topics in the same one, was because I was wondering if I did a corrupt install or something wrong that may have caused unreal to not work properly.

Thanks for any help

hello , fixed it , in case anyone is intrested , I’ve clicked “verify” in the launcher for my unreal version , I think it checks corrupted file and fix them for you, now material editor works.

hey
I am actually having this EXACT issue, but i cant see the verify option you talk about - is this in the EPIC Games Launcher // Library // Engine verion?

or on the Editor side when selecting from the templates?

i cant find “verify” anywhere

The ‘verify’ option didn’t work for me, but for those seeking to try and can’t find Verify, click down arrow next to launch…

image