Download

Material allignemnt problem

Hi

Just started using UE4 and i’m still trying to find my around it.
I can’t seem to get the materials on surfaces to align at all. i’m using bsp and i’m pretty sure all the surfaces are seamless, as I heard overlapping surfaces can mess with alignment.
the size values i’m using are also round, even numbers like 100, 200, 500, 600, 700, 1200, 2200 and so on. what am I missing here? is there any way to automatically snap all the floor surfaces in place just in case they aren’t perfectly aligned?
Appreciate the help

Do you have problems with every material, or just some few ones? + make sure to post a picture of your problem :slight_smile:
Normally when you edit the brushes with the bsp edit mode, it should keep the tiling right + it will also align properly → otherwise you can always change the position of the texture (details panel of the bsp brush → scale, rotation, alignment,…)

Capture2.PNGbf5ea0da680ccd8f5b16a0720b0c956fc9a3dd42.jpeg

Here are two examples of the kind of problem i’m having. I’ve already tried changing the size of the textures and angles and it never lines up. I’ve seen a lot of people complaining about this issue with this version. not sure if it’s the build version or if i’m doing something wrong here

On your 2nd picture you use several BSP brushes? -> just use one large brush for the floor (not the best fix, but it will work) :slight_smile:
For the other things I will have to do some testing

thought about it, but that section isn’t exactly rectangular. plus I have two sections with different textures. can I merge all the brushes into a single one? or maybe shape the brush to different shapes either than rectangular? I’m still not very deep into this engine

well, tried converting the brushes into a single static mesh and it still has the same problem. seems like i’ll have to make due with a single large floor brush. I left the wooden part 1 uu on above the tiled floor, which looks nice, gives it like a 1 cm difference in height between floors materials. for now it’ll have to work but I’ve read this is a bug on the current build. the previous build it seemed to be working fine. hopefully they’ll fix it with the next build