Download

Massively speed up light building and shader compiling! adjust UE4 affinity to LOW

are shaders, and light building taking you a long time? Since those are done as other tasks setting UE4 priority to low will give the light building and shader compiling priority over the UE4. It makes it go much much faster. at least on my i5 3570k. I would guess maybe on an i7 you won’t get such a speedup. But on slower machines especially ones slower than mine, it can help a lot.

Thank you man!!!

And also after you set UE4 to low set an application called Shader Compile affinity to High

Thanks so much!!! I have been going crazy trying to make materials. Just changing the base color was taking up to a minute and everything else much longer. I found a lot of tips to change the priority of the shader workers but I never thought to change the priority of the UE4 itself down to Low. WORKS LIKE A DREAM. If I could I would invite you out for a beer or something. Thanks so much!!! :slight_smile:

Thank you :slight_smile:

On top of that you might want to look into material instances. They make exchanging maps, colors and other parameters a lot faster, without having to recompile the base shader.

Like Zbrush or other sofware like that , maybe UE4 need a multreading/stress/build Test and make some auto setting.

Already was doing that, but thanks. The problem was making the material to then instance. The instanced material loads right away even without using the task manager to set priority. But like i said thanks for the tip anyways.

I just found this, could someone please explain actually how to do this? I know nothing about ‘affinity’ so a basic guide would be great. Thanks :slight_smile:

I would also like to know :stuck_out_tongue:

Task Manager - Details - right click the exe - set Priority
it’s Priority btw, not Affinity (Affinity is only to associate it with CPUs/cores)

thanks for the tip btw, wasn’t aware of it :smiley:

Ah sweet! Thanks!

Does this actually speed it up?

I’m not seeing any substantial changes in build time by setting: The engines priority to low or Swarm and Lightmass to High. I’ll do a few more builds tonight and share the comparisons.
I7 6700 3.4ghz
32gb

Wow that actually works, and pretty well! Thanks for the wicked trick! However it does feel slightly hacky - I like the suggestion from **EchelonV **in regards to Material instances on top of this. Would likely just set the priority to low for a temporary fix, and look at optimising the Materials via creating instances.

IT REALLY WORKS! SUPER! Lots of thanks! :smiley:

it doesn’t work at all. I 've set Priority to Low for Unreal Engine, and the Shader Compiler to High and even created a material instance. It takes 20 secs to compile shaders each time. I am trying to change a refraction value and this is making it impossible to work with. Why is everything with UE so ■■■■ complicated? There are so many people talking about this issue on so many different threads and there is no solution… I have worked with Unity, Sketchfab, Marmoset, 3DCoat and none of them had this issue. I even had to research how to import a model from 3dsmax to Unreal for god’s sake because apparently you have to be working in meters inside 3dsmax but export in cm!!! Everything about this engine is so counter intuitive!

At least, this worked for me.
I have been stuck for an hour always when materials are being loaded but setting different priorities on this tasks, worked and got forward.
Thnx

This might be a language barrier, but I’ve been trying to find the affinity settings, but couldn’t find it. Could anyone perhaps explain to me how this is actually achieved? Thanks!

@**fartwork69 **see post #11 for how-to

@**BYOB3D and ThanosBob **it’s possible your machine specs are too high for this to help, and you have a different bottleneck

@**DebellicA **it’s definitely hacky and so it helps to know what’s going on, i’ll break it down for anyone interested:

  • apps normally run at normal (0)
  • UE4 spawns compiler threads at below normal (-1)
  • we fix this by setting other apps to low (-2)

if we take this route, we actually need to set ALL apps to low. EpicGamesLauncher will start hogging CPU immediately, and i turned off firefox.

alternately, the idea of setting the shader compiler to high (+2) should fix everything with no other changes. but I could not figure this one out, the shader threads keep coming and going for me.