Massive UI Lag in Blueprint UE5 Editor [UE5.0.1]

I’m getting 5-15 seconds of delay in the Blueprint editor when trying to drag nodes, drag off nodes, or right clicking to get to the context menu.
Zooming seems unaffected, and once the initial lag is gone, nodes can be moved without lag for a bit, but anything bringing up the context menu for new nodes will always cause the 5-15 second hang.

EDIT: The lag seems to extend to blueprints in general. Editing in the viewport (moving/deleting) can have a similar long hang time.

This is for blueprints comprising of 20-30 nodes, so not huge.

By comparison, editing blueprints in UE4.7 there’s a 1-2 second delay for much larger and more complex blueprints.
In UE5, this lag is relatively small 1-2 seconds for small blueprints, but seems to ramp up in delay time as soon as more nodes are added.

GPU: Nvidia GeForce 1080
RAM: 32
CPU: i7 3.3Ghz
I use 2 displays. an ultrawide and a 4k.
Plenty of disk space, as I said works fine in 4.7 & 4.6

As for lag in the editor itself, very minor delays when creating new objects; but nothing beyond what I expect.
I’m using Nanite and Lumen, but disabling those does not improve blueprint editor performance.


I was experienced this myself and was struggling with the engine for days trying to figure it out. Almost went back to UE4 to finish my project! I noticed my fps was dropping from 100fps straight to 10fps when I opened my character blueprint and had it opened on my other monitor or even on the same one just having it opened at all was the issue. This same blueprint ran without a hitch in UE4 so I thought it was my PC being underpowered. After doing some tests I realized that UE5 doesn’t play well with a lot of blueprint logic on screen. You’ll notice it tank when you zoom out the view of a large area of blueprint logic. So going through all my code I just collapsed each section and overall cleaned up my BP and now the editor runs at a solid 60fps with the blueprint open. I can even set my engine scalability settings (which I initially put to LOW just to fix the issue. Did nothing lol) back to High or Epic without a hitch! I know it seems obvious to clean your code but for UE5 it seems extremely necessary for it to run well. Which is fine. I’ll improve my cleanliness from this point forward. Anyways Hope this helps you with your framerate issues!

GPU: Nvidia GeForce GTX 1080
Ram: 48GB DDR4 (32+16)
CPU: i7 7700k 4.2GHZ

1 Like

I was having this issue as well.

  • Go to Edit > Editor Preferences > Performance, and ensure there’s no FPS limits set there.
  • Additionally I found loading a completely different level seemed to fix this issue. Even if the level I was previously loaded into was less intensive, just the swapping of levels caused the editor to “refresh” and shoot back up to 120 FPS.
    Hope this helps.

I’m using UE 5.0.3 BTW.

I’m having the exact same issue, importing a blueprint level from an FBX scene. Whenever I edit the blueprint each time I select a different object I got 10s of freeze. It’s totally unsusable …

1 Like

Just realized, I don’t even need to open the drop down for it to drop fps, I just put my mouse over any of the menus (file, edit, window etc) and suddenly I have 5 fps.

I think I’m having a similar issue when I click any of the UI elements my fps drops to as low as 10, while if I close all the UI elements I have 100+ fps in the scene.

for example, I click file on the top left corner and as soon as the drop down menu opens I have 10 fps and It even takes seconds to highlight what I’m hovering on.

getting a similar issue, but in the UI widget editor. im using 5.1 and my performance in the node editor is fine except for when i want to copy, paste, or undo, in which case ill get several second stutters. this is for very simple things, like 3-5 nodes in an rather small BP (only 50 nodes total).
the widget editor is extremely bad. even something simple like moving a few text inputs can take several seconds, both using your cursor to drag them around, and move them around with arrow keys.
UE4.26 didn’t have any kind of issue like this and its extremely frustrating; productivity has legitimately tanked because of it.

i managed to get it working better. i dove into my editor settings (not project settings) and changed some stuff around. im not sure what i changed but my performance is considerably better (not quite as good as UE26, but mush better). if anyone is able to find the setting that fixed it for you, post it here.

I think I finally fixed it!
Turns out it was possibly the tooltips causing lag. I turned off a bunch of things in my Win10 Appearance/Performance Options, especially the ‘Fade’ ones, and it’s really smooth now!

I posted this to reddit with an image of the windows settings I have.

oh dang. thanks for sharing