Download

Massive memory leak in Blueprint Editor introduced with Unreal 4.9

Hi,

we just upgraded to 4.9 and we immediately encountered a big issue with memory usage. Just by leaving the blueprint editor open, Unreal keeps allocating memory until the system memory is exhausted. Our team PCs all have 24Gb of RAM, which have been more than enough to work for hours with Unreal 4.7 and 4.8 over several months, but now it takes only a few minutes of work to reach the point where the system becomes unresponsive.

I am attaching two screenshots showing the memory usage pattern: in the first, Unreal is launched and the project is loaded. About 2.8Gb of memory is allocated and then a plateau is reached. On the second screenshot (attention: the scale is different), I just opened the blueprint editor for one of our most complex blueprint and just waited. As you can see, the memory usage started increasing linearly and didn’t seem to come to a stop. It took only a couple of minutes to get to 13.4GB when I made the screenshot, but the increase did not stop even afterwards.

Is anyone experiencing a similar issue?

I am not experiencing this issue, my editor has been opened for 2 days and I am sitting at 2GB usage, are all of your team members using PCs with the same specs? If so it may just be your setup as you are the first person I’ve heard about this issue from.

Not had this problem yet, and I’ve got two pretty complex games under my belt at the moment.

I assume you guys use source Control? I’d go back to 4.8 and check again what happens there. It might be that in moving to 4.9, someone mistakenly corrected or rewrote something in the process causing the leak. Does happen!

I have the same issue since upgrading. First time happened within an hour of upgrading, crashing my machine (it was using ~14GB of memory). Now, I usually can work for about 1-6 hours before the editor needs a restart. I have been keeping task manager open and watching memory usage. When I do a save all while working in blueprints, I notice my memory usage climbing. I am glad I am not the only one seeing this.

Of course we have source control, but going back to 4.8 seems like a waste of time to me. We know that it worked flawlessly with 4.8. During the migration to 4.9 we only had to merge a very few (about five) changes to the engine code and I reviewed all those merges personally, so I would rule out it’s one of those.

Glad I’m not the only one. It may be that the memory leak occurs with other blueprints, but we a single one that is particularly big and is know to have cyclic dependencies, which is particularly troublesome. If you just leave the editor window with that BP open, the memory allocation skyrockets and kneels my PC in a few minutes: it occurs 100% of the times, the pattern is the one described in the OP. We resolved by trying to only do small edits on that BP at a time and to remember to close the editor window as soon as possible, when not needed.

I have the same issue and captured a short 2 min video

- YouTube

I don’t have anything like that either, there might be some specific cause, you have the same on empty project?

Need testing, empty project seems ok. The memory leak in my project happens after work awhile with blueprints, open/close then open again some blueprints. Blueprints compile well, with no errors.

I converted and migrated some blueprint logic from another 4.8 version project maybe that is the case.

I’m having the same problem. Converted project from 4.5.1 to 4.9.1 and while editing blueprints RAM usage will creep up until Windows complains about it.

Try to find exact point where leaks starts this way it will help to pin point the fault

Okay, this is strange. I did some more testing and in my case it was a particular blueprint that would case the RAM to balloon as long as it was open in the blueprint editor. I tried to replicate a particular circular reference involving an animation blueprint and a pawn blueprint in an empty project, but it didn’t cause the problem.

Back to my own project, I noticed I had a large amount of tabs opened in the blueprint editor which came along from the migration from 4.5.1 to 4.9.1 for that particular blueprint. I closed all of them but the viewport and the RAM usage stopped increasing. I even opened some of my graphs and it’s still stable. I’m not sure if it was the amount of opened tabs or if there is a particular function graph that triggers it (this BP has a lot of functions), but I’ll keep an eye on it and report if I find anything else.

For those who migrated their projects, try closing all blueprint editor tabs and open fresh ones.

For what it’s worth, I just tried the 4.9.1 hotfix, testing the very same BP that was causing the leak in 4.9… The leak is no longer present or so it seems. Has it been fixed?

Happened to me in 4.9.1, actually. But as I said, it stopped happening after I closed all graph tabs for some reason.

I am getting a massive memory leak when my blueprints are opened, didn’t happen before 4.9.

4.9.1 - Windows 10 64bit

I am also getting massive memory leaks after working in blueprints in 4.9.1. If I don’t take care, it ends up taking down my machine. Didn’t see this problem when working preview versions of 4.9.

I’ve been seeing this since I updated my 4.9.0 install to 4.9.1 as well. Running 4.8.3 and 4.9.0 concurrently was no problem. A single instance of 4.9.1 will eventually pin my RAM usage at 100%. A second running instance does it in about 10 minutes.

Completely new C++ project, too, so I’m fairly confident it isn’t anything from a conversion process causing the issue. Blueprint could still be a culprit, though. I use it almost exclusively when sketching.

Edit: This actually appears to have been launcher related for me. Being vigilant about closing the launcher has curbed the issue entirely. YMMV, though.

I also just experienced the memory leak in 4.9.1. UE4 was running in the background for the last few hours without me using it and then I wondered why my tabs in chrome are loading so slow, so I opened the task manager and saw that UE4 used 10.5GB of RAM, so my 16GB were full. The regular RAM usage for my project is about 3GB to 5GB.

Is this leak already fixed (in master branch or 4.9.2) or is Epic still investigating whats causing it?

Maybe this thread should be moved to the feedback section?

I’m experiencing this too right now. I can probably use the editor for less than 10 minutes before I’m out of memory and have to close Unreal :confused: