Massive Memory Leak In 4.10.4

Really not much to say, editor devours through my ram in minutes, and when i shut down the editor it has problems freeing all that memory. i have memreports of when i start engine up and after it eats all my ram

link text

link text

Hi Lifeburner,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps do you take before this occurs?
  • Do you have any specific sub-editors open when this memory leak occurs?
  • Can you post your dxdiag here so I can take a look?

link text

here is my dxdiag report, and as far as i can see this does not happen in a blank project. I dont do anything for it to happen, it always seems to do so in my editor. But i used to be able to use the editor for maybe 40-50 minutes but now it cant stay open for longer than 5-10 minutes. It changed after i edited and added some particles to my map, added an inventory structure and array, and added widget components for the first time
i use mainly Blueprint editor and i dont think i used any other sub-editors for the last one or two days

Blueprint editor has memory leak which as far as i remember was fixed in 4.11. It’s related to opened function windows in editor.

What do you have in the level that you are experiencing this with? Your computer’s hardware is limited and may have difficulties. Try 4.11 as CriErr stated to see if the memory leak halts. If you are still crashing after this, it may not be a memory leak and may be due to too much strain on your hardware.

Alright now, i started installing 4.11, and i had an error. So i did what any sane person would do, acted like nothing happened, deleted it, and reinstalled it. It now gave another error. changed nothing, installed again, and somehow it works. Also no more leak(as far as i can see)! Thanks everyone for your time.