Marketplace Purchases broken: An error occurred while trying to process your request

I get this error when trying to purchase a $2.5 asset. And I got it when adding $100 to my account from CC (eventually worked, but the $2.5 hasnt worked 3 times):

An error occurred while trying to process your request. Please check your network connection and try again.

  1. I spent $300 and made 20 purchases last month without error. What did you change that this is now broken? Now Im scared that I’ll miss the sale if this isnt corrected in 4 hours. I also opened a New window and tried again, still error.
    I dont want to reload my 30 tabs. So is this a you error (network CC processing), or a me error (my browser/cookie)?

  2. You also changed that every 24 hours, my browser cookie gets signed out if I go to sleep, wakeup, refresh the tab > it redirects me to an ERROR link (and im signed out).
    And if I go to my bookmark for Free content > redirects me to ERROR link (even if I signed in another tab). Im using the exact same browser and addons from last month.

EDIT: I had to close my browser and 30 opened tabs. Reload. Now the $2.5 purchase went thru at the Buy page. But the redirect turned fully white, and did not finish loading to refresh the asset page.
(I manually refreshed after waiting a min of nothing happening. And the Asset page now said I owned it.)

But I am very scared that my purchases arent going thru or if I think I need to buy again, and get double charged. What did you guys change???

Problem 1 has returned. I cant add funds to my wallet again (which I was able to do 5 mins after making the first post, and able to do 3 times last month without any error).

I opened a new tab. Made sure the login cookie was refreshed. Clicked to buy something > Clicked to add funds > typed in my CVV > clicked Add funds >> The error displays.

I already spent $100. If you fix your problems in 15 mins you can get more of my money. Thank you.

Edit: Something is wrong with your servers or AI. I missed sale items.

  1. After this post, I closed all tabs, restarted FIREFOX browser.

  2. Loaded a bookmark of the Marketplace.

  3. It got the same ERROR redirect where the Marketplace link will not load or even let me refresh (srsly I was just logged in).

  4. So I had manually type in the unreal domain name > to go to Market > Browse assets.

  5. But now the Marketplace server was not loading (the page wouldnt load - while I checked and this Forum server/page did refresh).

  6. Time running out to buy. Finally the Marketplace server/page loaded.

  7. I went to the asset > Buy > try to load $100 > failed.

  8. I rushed to use a different BRAVE Browser I never used to sign in. Rushed to type in pass.

  9. It loaded > try to add $100 then $50. Now it gave me a Declined error. Why?? (My card is linked to my bank and it has funds.)

  10. So instead of adding $100, I bought the asset after typing in my CVV. It worked yet adding funds doesnt???

  11. Rushed to buy more assets on my Wishlist (I had to delay buying because I was waiting on Dev answers, Ive been preparing what to buy for 4 days.)

  12. Sale ended while I was still clicking. Couldnt buy all I wanted.

  13. ???

  14. No profit? :frowning:

  15. If this is your AI screwing around with false alerts, admin PM me and I can give more details not in public. Because my browsing activity/addons used were the same as last month, which worked to give you $300. (I did 3 x $100 refills in a row, after some delay spending the first $100.)

“Your credit card’s limit has been reached and has been declined.”

Update: I am still getting this error in Firefox. Is no one going to fix or address it?

This error is false. Because right after I tried to purchase in Firefox (using an already setup CC) - I signed into Brave, and the SAME card worked without error.

  1. So this tells me it is a cookie issue with Firefox or something. I have not updated Firefox since this issue started. So did you change some code that broke Firefox/cookies?

  2. Or have my cookies become damaged and I must delete?

  3. Also I signed in fresh, so whatever cookie is messed up, should have been refresh-fixed. So what is the issue?