Marketplace purchase broken?

Hi Michaeleeli,

Thanks for informing us, we have immediately escalated this issue. We may require more information from you, in the mean time could you please provide us with a debug log of a run where this occurred.

You can find instructions on how to do so here:

The new marketplace update a few minutes ago seems to be broken (at least on our side).

After pressing to purchase something, it asks for the login information - but you can’t get past this as it keeps telling you your combination is wrong. We tried logging in with the same credentials for the launcher and it works, just not for the marketplace. It also makes the mouse stuck with a stop icon. Pressing “Need Help?” will freeze the launcher. This is happening to two of our computers.

Anyone else getting this problem?

Just to confirm, have you attempted to purchase an item directly after having logged back in? Ensure that you re-enter your credentials and not rely on the remember me automatically logging you in.

There is a known issue causing the marketplace to have issues after running for some time, re-signing in fixes that temporarily.

A fix is in the works.

Yep you were right, I had to sign out of the launcher and log back in without the “Remember Me”; it would then allow me to purchase things. Unfortunately I don’t have the debug log from the previous run. Sorry!

As long as this workaround solved your issue we wont need your debug logs, as it means its a known issue.

Apologies for any inconvenience caused, we have a fix in the works.