Marketplace plugins skipped during packaging project in source built engine.

I have marketplace plugins working in editor, but when I package my project it “skips” the marketplace plugins and errors out complaining that the plugin isn’t there (obviously because it was skipped).

What I have done:

  1. Installed launcher engine 4.25.4
  2. Downloaded marketplace plugins and installed to launcher engine 4.25.4
  3. Built source engine 4.25.4 (oculus branch as I need quest 2 compatibility)
  4. Copied marketplace plugins to source engine
  5. Built source again
  6. Launch project agreeing with warnings/errors
  7. Enjoyed plugins in editor and preview
  8. Packaging fails throwing a bunch of warnings and errors
  9. Question my life choices that lead to this moment and resist the urge to build a cabin in the woods far away from any technology…

The warning/error when I launch project:
“The ‘xxx’ plugin was designed for build 4.25.0. Attempt to load it anyway?”

And when I package the log warning:
LogPluginManager: Warning: Plugin ‘xxx’ is not compatible with the current engine version (4.25.0)
LogPluginManager: Display: Skipping load of ‘xxx’.

I am confused as to why the plugins work in the launcher and not source of same version, but ultimately would just like to get this project packaged.

1 Like

Running into the same exact issue, but im on Oculus 4.25.3

Ever find a solution to this, I’m in the same boat.

Has anyone found a solution for this? - I also find myself in the same predicament.

To anyone that may be having similar issues, I managed to resolve it by doing the following:

Open XXX.uplugin with VS [Your preferred version of Visual Studio]

Remove the following line completely: “EngineVersion”: “4.26.0”,

Save and then rebuild. It worked for me, I do hope it helps others as well :slight_smile: