Marketplace Broken


I cannot click on any of the content in the marketplace or the learn section. Whenever I click on anything nothing happens. Using an external link to download a content pack yields the same results. (like this Animation Starter Pack in Epic Content - UE Marketplace) clicking on the download link brings up the launcher then nothing happens.

I have tried different versions, restarting my computer, restarting the launcher, using different computers, using another account. Nothing I have tried works and no solutions could be found online.

Any ideas on how to fix this problem? In a rush as I need to download some content for a school project.

I’m having the same problem as well. The launcher isn’t the only problem, I can’t open the marketplace within unreal engine either.

I fixed it by disabling my VPN. If you’re not currently using a VPN, I suggest you try one and see if that resolves your issue.

I also have this problem. I’ve disabled the VPN and the issue persists…