Map won't load / deleted itself from content

So yesterday I was working on my project as always, using UE 4.12.5. After saving, took my computer home and when I tried to open the project, the message “Failed to open map file. This is most likely because the map was saved with a newer version of the engine.” showed up, but I didn’t updated the engine or anything. When the editor loaded up, the world was blank but my assets was still safe in the contend browser (BIG relief). I was using the FirstPersonExample map, so I searched the content but I couldn’t find the map anymore ( I did not deleted it though). Went to windows files and the .umap file was still there, but I can’t import or whatever for the project. Tried to download a new version of the engine but I get the same problem, and already tried to create a new project and copy/paste all the content, didn’t work either. What can I do and why the hell? :frowning:

Hi Rbacch,

Check to ensure that you did not open a different engine version first. This is simply to rule this out as a possibility. Once you have done this, try verifying your engine build by going to the Launcher>Library>Engine version dropdown version>Verify. This will check your engine version to see if any files are damaged or missing and repair/replace them as appropriate. After doing this, try opening the map/project and see if the error still occurs.

Hi . Thanks for the reply.
First, i’d like to say that I just have one version (current 4.12.5) installed, so I think that’s not the problem.
I’ve verified but the engine was not the problem. Didn’t had any corrupted files or anything like it. Still getting the error message though.


I just tried, in the editor, to create a new Level Map and rename with the exactly same name as the “deleted level map” (FirstPersonExampleMap). As I suspected, it didn’t allow me to create this map because it already has map with the exact same name, but it’s not showing on content browser.

Checking the logs, i found this line:

“[2016.11.02-19.40.21:233][ 0]Cmd: MAP LOAD FILE=”…/…/…/…/Projects/Consciente/Content/FirstPersonBP/Maps/FirstPersonExampleMap.umap" TEMPLATE=0 SHOWPROGRESS=1 FEATURELEVEL=3"

“[2016.11.02-19.40.21:247][ 0]LogLinker:Warning: Unable to load package (…/…/…/…/Projects/Consciente/Content/FirstPersonBP/Maps/FirstPersonExampleMap.umap). Post Tag is not valid. File might be corrupted.”

Did I just lose my whole level due to a bug?

Updating with answer:

Ok, so digging a little I found out that my map was really corrupted and won’t load anymore. BUT in the …/projects/“yourprojectname”/saved/backup folder, there is an .UMAP file. Just duplicate this file and write the SAME NAME of your bugged level map. Now Ctrl+X this file, go to your project’s Content folder, navigate to where your level map is (mine was at FirstPersonBP/maps), delete the level map and just paste the file from the backup folder. This should load your last saved map.

1 Like