Map not cleaned up by garbage collection

Hi, I have encountered a certain problem the last time…
When I use the Open Level node, my game crashes with the message, that my map is not garbage collected. Exactly:

World//Game//Maps//UEDPIE_0_MapName.MapName not cleaned up by garbage collection!
(Object is not currently rooted)

I have the feeling it stopped working since I used an UMG Widget in my level.
I tried to call Garbage Collect before leaving, and removing all widgets from the viewport, but it doesn’t help.

Can someone help me?

I found out that it occurs only when I use Create Widget and Add to viewport. As I removed those calls, it worked properly.
Any ideas on this?

Hi,

I am new to game development and Unreal Engine 4. I am using version 4.6.1.

I am also facing the same problem.

I am trying to change the materials using UMG buttons in 3 levels (using UMG buttons) but I am getting the following error and the editor closes when I go to another level.

I even tried to remove the viewport i.e. remove the parent (user widget) before opening the another level. But still I couldnt fix this problem. I even attached my level blueprint here.

Can somebody please help me to fix this issue?

Thanks in advance!

cd4a86c32fb2cc8754f1be6c52af887d423ae7be.png

4d83e8ffd34fd72ad674ebfe388c13ce42b5dad4.png

I have encountered this issue before in 4.6. Removing the UMG widget manually at EndPlay does the trick. You will need to store a reference to it until then.

55f91e4d03a077b07a37138d92c71a0d9dff910c.png