Download

Map check errors

Whenever I rebuild geometry and lightning, I get a slew of map check errors. A couple I can list are “bounds scale too high” on some of my meshes. This is because on these meshes, at a slight distance the texture noticibly decreases and the only solution I’ve found is increasing the bounds scale. And also “uv overlapping error” on a few of my meshes. I’m creating this level in the UT level creator and I was curious if I needed to address these errors before I could submit it. They don’t seem to impact the performance at all. So I’m fine with just ignoring these unless it’s something I need to square away before finishing the level.

Hi,

I can’t really help you with the bounds error, but regarding the overlapping uvs, you most likely have some overlapping UV islands in the lightmap channel of your mesh that is being marked with the error.
I don’t know your experience with creating lightmaps, but you cannot have overlapping UV shells in that channel. I can provide you links about proper lightmap creation process if you need it.

I would appreciate that very much! Thanks.

So I’ve been looking into lightmap creation and I’ve noticed a lot of people are using blender. Is this required or can I do this within UE4?

Blender isn’t required, but it’s free so many indie devs tend to use it. You cannot create unique uvs in UE4. Lightmap generation in UE4 uses the existing uv map in channel 0 to generate one optimized for lightmaps.

Here is the link, it is actually part of the documentation:
https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/

Well I decided to fiddle around a bit before I had seen these responses and I seem to have gotten rid of these errors by simply changing the meshes to “stationary” objects instead of static. Not sure if this was the correct way to address this, but i don’t have anymore of these errors after a lighting rebuild.

Well, I’ve solved the overlapping uv errors that is. Still get the “bound scales too high” error after the geometry rebuild. Anyone have input there? Is this a crucial error that needs to be fixed? I hope not. With some of my meshes, increasing the bounds scale is the only solution I’ve found to keep the detail from severely decreasing from a slight distance. I can post pictures of this issue later if needed.

Don’t edit the bounds scale. It might not cause performance issues now but continuing to leverage it is going to cause problems eventually. Edit the LOD group for the texture instead to something that won’t MIP so soon. If that doesn’t help, you might simply have your graphics settings set too low.

Thanks! I’ll try the LOD group suggestion. It’s certainly not my graphic settings as I have them on high, and this issue only affects certain meshes. Everything else looks just fine.

To be real specific, the meshes im having these issues with are from the “red desert” pack from the unreal engine marketplace. All of the flora meshes provide this issue. They look fantastic close up, but at the slightest distance they noticeably decrease in detail. Like to the point where it’s downright ugly and the texture pop in when approaching it is incredibly obvious. And I’m using a lot of these flora meshes so I’d hate for this pop in issue to be scattere all over the map to where it’s being seen all of the time. I’ll definitely post comparison pics later when I get home. Pics show the default bound scale wth the pop in issue and pics with the bound scale increased with the issue solved.

Thanks a bunch interference, tweaking the lod settings has fixed this issue. More specifically, changing “forced lod model” from 0 to 1 completely fixed it with all of the meshes I was having this problem with.

Well, I do seem to have one issue related to the overlapping uvs. It’s for a mesh that I’ve actually deleted. So I’m not sure why I’m still getting the error. I’ve went through and checked and sure enough, I’ve certainly deleted the mesh this error is popping up for. Any solutions for this?