Download

MakeHuman > Blender > UE4 - Help Please

This is turning out to be a pain staking process. All tutorials online are dated now.

This first issue I am having is with scale and orientation. I have to import my mesh’s FBX at a 0.01 uniform scale and 180 degree yaw rotation. Even then the character is floating hall a foot above the ground.

Secondly, when I import the animation, the animation is completely broken. Bits of it are still there, bu the mesh is wildly misshapen.

Any ideas? Mesh, Animation FBX and Blender files are included here: Dropbox - BlenderHelp.zip - Simplify your life

In my case, the settings from THIS THREAD are working ok.
About character floating, i’ve had similar problem, CHECK THIS OUT.

About animation, do you have any errors/warnings after importing it into UE? Did you applied transform to all objects in Blender before exporting?

the tutorials can very quickly get outdated due to the fact

  1. if you use the MH nightly builds which can break or add things
  2. Blender gets updated , can add issues with fbx exporting
  3. UE4 gets updated/hotfix can cause issues when importing blender fbx files !!!

trust me it annoys the hell out of me after doing hours of tests and working out who/whats at fault and working out how to get round them. my answer is if its not broke why fix it , but the bottom line is that there are issues from all 3 programms and the devs don’t work together.

just post a tread or pm/email the people that posted the tutorials, you’ll actually find some people who are willing to help you along

I restarted from scratch and have gotten very simple animations to work just fine. I did nothing different and technology is magic.

That being said:

Under Smoothing when exporting, I only have the options “Edge”, “Face”, and “Off”. Choosing an option other than off disables the ability to select Tangent Space.

I get no errors importing a mesh, although I do have to scale it down by “0.01” and rotate it 180 degrees. I know the rotation is a common problem, but am I missing something with the scale? I set MakeHuman to export in centimeters, My Blender is scaled correctly and when I measure the height of my mesh it is 1.8 meters, but when I import, I have to import it at “0.01” Uniform Scale in UE, otherwise the mesh imports huge.

Updating my own post here because I know people are looking for MakeHuman > UE4 Workflow tips.

First, use the nightly build of MakeHuman (V 1.1.0). When exporting, export as a .dae in centimeters with Uengine rig. Use the default importer for blender to load your mesh. Export as FBX. Export animation as FBX with Amerture only selected.

When importing to UE. I had to downscale my mesh by 0.01 and rotate it 180 degrees on the Yaw. When import animation, I had to import with 1.0 scale and 90 degree rotation on Roll.

Update:
I imported a walking animation and the pelvis is crushed.

nice to hear you’ve found a workflow that works for you

Any idea on what could be crushing my meshes on animation import?

Have you tried using the latest fbx exporter that comes with Blender 2.74? A hacked solution was exposed that has fixed most problems with custom rigs.

I’ve uploaded a video of me going through the whole process which may help.

https://www.youtube.com/watch?v=rRqD17-3m0k

I’ve been busy texturing static meshes, thank you very much for the upload.

Actually, using makehuman 1.1.0, game rig option and export as FBX gives a great result in UE4. Can’t get it imported to blender decently atm tho…
Copied the default animations to my makehuman rig and it looks fairly decent… Needs some tweaking, but it’s something.

To import it into Blender don’t export as FBX from MH (because FBX import in Blender is horrible) but as DAE and centimeter (and finally as FBX from Blender for UE4 if you are done). Change scene settings to metric and scaled to 0.01 in Blender. MH 1.1.0 -> Blender -> UE4 works (https://forums.unrealengine.com/showthread.php?58944-Makehuman-gt-FBX-gt-UE4&p=366593&viewfull=1#post366593). Only issue is a bit different A-Pose and missing twist bones.

After struggling for a number of hours, I was able to successfully develop a workflow for makehuman–> blender 2.78–> UE4.15. I am very new to this community and am not a professional, but am hopefully that somebody will find this to be of use… The process is painful, but free and works a lot quicker the 2nd time you do it.

  1. Create and save makehuman character. Export to mhx2 exchange format with game engine rig, feet on ground and centimeters (do not check off binary). Also select hide faces under clothes or it will glitch later. I recommend having the character be around 185 cm (I think the guidelines say the mannequin is 180, but 185 matches better for me). Make sure to save in makehuman and in blender often with multiple versions so you don’t have to start over if you mess up.
  2. Open UE4_Mannequinn_c from the UE Tools Pack designed by Lui https://forums.unrealengine.com/showthread.php?34619-ADDON-BLENDER-UE-Tools Note: this looks great, but I couldn’t get it to work as intended, so just using the template file gets the job done.
  3. Delete the two mobile layers to the right. Select edit mode. Go to armature. Select the 2nd through 4th layers holding shift. Press the b button then select everything then del key then delete bones. This leaves you with one armature layer of just the UE4 bones and one mannequin layer for the sake of comparison.
  4. Switch back to object mode. Import your mhx2 file in a new layer. Note: must have makehuman addon to blender installed. There are other tutorials for this.
  5. cntrl + J = Join all makehuman objects in object mode.
  6. Select mesh and bones using shift click. Press m to move the objects to the first layer.
  7. Here comes the tricky part… Use the make human bones in pose mode to adjust the mesh to match the epic bones. It doesn’t have to be perfect, just close.
  8. In object mode select your mesh. Click the little wrench make an armature (click apply) to keep the mesh deformed the way you made it to match the epic skeleton.
  9. Select the makehuman skeleton in object mode. Switch to edit mode. Press b and select the whole makehuman skeleton. Delete it.
  10. Switch back to edit mode. Select the mesh first (very important) and then shift click the epic skeleton to select it too.
  11. Do cntrl + P to parent your makehuman mesh to the epic skeleton. Select automatic weights.
  12. Select the bones. If they are green continue, if they are white hit cntrl+tab to make them turn green. Go to object mode. Select the mesh and hit cntrl+tab to change to weight paint mode. The set automatic weights will get you close, but you will most likely have to manually paint some of the weights. If you look at how an epic skeleton is weight painted you can use that to model how you weight paint.
  13. Delete the mannequin in the bottom layer.
  14. Export as an .FBX file using default options.
  15. Import fbx into UE4 using default options except check the advanced option ‘use T0 as reference pose’ and 3rd person demo project to start testing.
  16. Select the mannequin folder->animations and retarget the 3rd person animation blueprint by right clicking on it and selecting retarget->duplicate and retarget. In the next screen UNCHECK show only compatible skeletons. Retarget to your skeleton.
  17. To actually play your character, go to mannequin folder->meshes->and retarget the skeleton to your skeleton. You should be able to select your character from the dropdown now instead of the mannequin.

I think this is still a bad idea. MHX2 is no part of official Makehuman anymore (MHX1 was in the past but they removed it at 1.1). That means you would use an unofficial plugin and the export is not CC0 anymore but AGPL3 instead (because only unmodified versions of Makehuman gives you the CC0 exception). This sideeffect (especially regarding MHX2) was already discussed at their forum. In short - AGPL3 is incompatible with UE4 as it contains a very strong copyleft. I would still recommend using DAE (or FBX if you would use that auto-blender script) as export or probably try Manuellab (as it contains twist bones with 1.5).