Download

Make the launcher not auto-start with projects

I know this has been asked many times, but I am asking it again. Dear Epic, please make it so that the launcher does not automatically start when I launch my UE4 projects.
The launcher is a slog, it costs an extreme amount of hardware resources just to sit there idly in the background. I know this is because it was build with Unreal Engine, but there is zero reason to force it to launch with a project. It doesn’t do anything to my projects while I work on them!

If I want to start a new project or add assets, I simply start the launcher manually myself, add the assets or start a new project, then I close it again.
In fact, the first thing I do when I open my projects is to close the launcher, because it slows my system and my editor down so much.


EDIT: The simplest fix seems to be to go to your “…\Epic Games\UE_4.25\Engine\Build” folder (or your engine version) and create an empty text document and name it PerforceBuild.txt

This will make the launcher not auto-start anymore when you open the editor.

Response from Epic:<Tumbleweed>
Good luck with that request dude. :stuck_out_tongue:
Why not learn to just disable it???

Here is the right place to request it: https://epicgames.questionpro.com/t/APBTQZhgxW

Instead of being snarky, why not be helpful and explain how?

Brute-Force-Method… But there are others if you do a title keyword search on ‘Launcher’.
For example you can also alter the Registry-key below (rename Command to Command1).
This has the advantage of keeping the Launcher ‘available to you’, while not auto-launching:


HKEY_CLASSES_ROOT\com.epicgames.launcher\shell\open\command1

That said… Be careful as the Launcher also adds a Registry ‘RUN’ key at Windows Startup.
If you don’t disable this key it will auto-start the Launcher in silent mode at startup (sneaky).
Profiling the Launcher shows it does other questionable things too that aren’t documented!!!


HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

BTW:
Always export Reg keys first before changing anything! Win7/Win10 Start->Run regedit

Thank you for that info, greatly appreciated !
I ended up using an empty PerforceBuild.txt file instead now, as I couldn’t figure out what to change in the registry.

Yeah we all remember the information sniffing debacle regarding the launcher…
I already have it set to not launch automatically, and since I always check my tasks running every day I would notice if it did somehow. I still expect it to set it back to autostart with any new update though…

By the way, if you know about other things, why not document it make it public?