Make the character not slide on the floor

I made a walk animation in 3DS Max for my character. But when he is walking he is sliding on the floor. How to fix it, so he won’t slide and be confident to walk on the floor?

Hey there, if he is sliding then your character movement speed is faster than the animation, you can fix this by either adding root motion or lowering the movement speed.

1 Like

Can you answer one more question? My character has controller assigned and the controller find target point to move to. But when he needs to turn he does it too sharply. How can I make him to rotate smoothly?

That is another question altogether, but you can enable the Orient Movement to Rotation in the character movement controller and use the Rotation Rate to define how smoothly it rotates. If your question was answered please mark the answer as correct and upvote it if you found it helpful.

Good to know :slight_smile:

That works great! Thank you very much!