Make Issues [Fedora 26]

so lately i switched from windows 10 to fedora 26 and i have tried to install unreal engine 4.11 i get the same error message every time:

I have searched and couldn’t find fix for me … please help. thanks.
btw i even tried to install it 3 times on a vm.

EDIT: so i kept trying to fix it and i installed a newer clang ( 3.7.0 because i had 3.5.0 and probably its not compatible with UE 4.11 ) and still same error.
so i tried to compile hello world c++ with clang and now i have

hello.cpp:1:10: fatal error: 'iostream' file not found
#include <iostream>
1 error generated.

so i believe its the clang that making problems…

It looks like you don’t have C++ development packages installed on your system. By the way, I would suggest building a more recent version of the engine.

thank you for your answer, so nobody answered to me so i kept trying and it wasn’t successful. so i deleted fedora and moved ubuntu 17.04 and i followed the instructions now everything works just great.
and I’m using unreal engine 4.11 because i have no idea what to do one the new persona of the new versions, and for me its more comfortable.