make human and retargeting


I board a small problem for make human when using my personal and retargeting for this tutorial I’m doing all my bones that focuses one point that the animation plays but I did more than that mesh and how that one knows why its not working

sorry for my english What if that one I could speak french better detail the problem

thank you for your understanding

called me which part of the message you do not understand





More than that mesh? You mean bones? Maybe try this tutorial: - It’s using a different but similar skeleton and was done step by step.
Actually makehuman skeleton works with UE4 but A-Pose differs a bit ( You have to adjust hand and fingers (so it looks a bit more similar to the UE4 mannequin pose) or rotations looks wrong and you have to add a few twist bones or some animations would cause your lower arm to look like some narrowed ballon (for example with rifle animations).

So you advise me to export the hero tpp import in blender and adjust my character as the hero tpp?

Export makehuman as dae in centimeter (I would recommend the game skeleton… or at least a skeleton that does not contain a crazy amount of useless bones). Export SK_Mannequin (for example from the third person template) as fbx. Change scene size of Blender to metric and scale to 0.01 and import the makehuman and UE4 skeleton mesh (use automatic bone rotation for the UE4 mannequin import) into Blender. Make the makehuman pose of your character look as most similar as possible to the UE4 mannequin pose. It’s ok if the bone sizes differs (e.g. difference between a male or female skeleton) but rotate the arm and fingers so they look at least very similar. If the bone names are different then you could rename them right in Blender as well (so you don’t have to map them manually later in UE4 if you import different versions of your model again and again in UE4). Additionally I would recommend to add some twist bones at least for the upper and lower arm. Take a look at the UE4 model in weight paint mode of Blender, search the twist bones and look at the weights. Add a few bones to your makehuman character (same hierachy as the UE4 skeleton) and paint the weights so they look similar as well. Otherwise some animations would look like this:

ok I’ll try tomorrow because I board spend six hours to find a solution and I think you 're going to walk even if google translation and thank you very bad lol I would return tomorrow

So here I board half works well but I do not know what has parir his bones bug


Did you set translation retargetting to skeleton for all bones except root (which should be Animation), pelvis (which should be Animation Scaled) and IK bones if there are any (which should be Animation as well)? Like this:


Is there something wrong with your spine_02?

thank you was that its well I still have not worked that a small adjustment to make and should be good thank you very much


but it will do in the blender xD

Last question my character shrinks when I import my animation


my character :

I had some spare time while doing some diskdump so I took a look on your mesh and it looks almost ok after tweaking it a bit:

+) Removed all those _end and _end_end bones. I would recommend to avoid to export leaf bones in blender.
+) Fixed the Restpose:
-+) Applied armature modifier to all mesh objects in Blender (so the modified pose would not change if the armature would be removed)
-+) Selected the armature object and switched to pose mode and did “Apply Pose as Rest Pose” in Blender.
-+) Finally choosed all mesh objects again in Blender and readded again a Armature modifier to all of them (and choosed the already existing armature).
+) Selected all objects (all meshes and the armature) and applied scale and rotation in object mode of Blender.

Exported from blender and imported into UE4. Retargeted free anim starter set and few third person anims. Result:


Export and import settings (edit: Export settings screenshot is from 2.75 blender but I used 2.76b which has more tabs. I usually use this settings for animations and leave all options enabled in the Animation tab of the export settings in Blender if I just export a skeleton mesh without animation):



thank I’ll make her just now because I just discover a big problem (state machines ) xD it will take me a long time to understand anyway thank you for your help