Make an In-App Purchase node does not work correctly

The “Make an In-App Purchase” node does not work correctly.

Neither On Success or On Failure will execute unless you execute the node twice. It’s not a problem of not waiting long enough, the exec outputs simply never fire.

This is the solution I had to go with

http://puu.sh/lidIP/1d70257023.png

The downside to this hacky solution is that if the user gets to the Google Play payment prompt, and then backs out the prompt is opened a second time, and the user has to back out once again.

Hey Rett,

We are aware that the Android/Google Play in-app purchase blueprint node only works correctly if it fires off twice. This bug is already reported in Jira and can be referenced as: UE-23190. Currently it’s unresolved at this time. Please feel free to follow up if you have any questions on its progress.

Thanks!

Is it safe to assume this bug is still in place for 4.10? I couldn’t find the Jira page, I assume it’s private?

Yes this bug is still there in 4.10. All the IAP is a disaster.

Hi, Is this solved in 4.10.1 ?

No. it does not work in 4.10.1… You need to still need to fire it off twice.

RichardSo said below it’s not working but I only have to call the make purchase once.

UE-23190 is closed and was fixed for 4.10.1. The changelist this was fixed in was 2772386 which is earlier than the changelist provided in the 4.10.1 hotfix.

Thank you.

Sorry I thought you meant 4.10. The list of fixes for 4.10.1 are documented here and addresses the two IAP issues below:

Fixed! UE-22157 Android In App Purchase can return false even though the transaction is successfully completed.

Fixed! UE-23190 Android/Google Play In-App Purchase Blueprint node only works if you fire the node twice

… and from our preliminary testing of the above, it seems to have fixed the issue… However restore purchases function is still not working though.

UE-23959 is currently unresolved in Jira. Please continue to check the release notes for each version of the engine, or check back here for any updates.

Thanks!