Main menu working in Editor but not in Standalone Game


I have created a simple main menu with a few buttons that either load a level or quit the game.
The menu works perfectly in Editor but not in a Standalone Game. When in Standalone game the buttons don’t even highlight when hovered over. Does anyone know what the cause of that is?

Any advice greatly appreciated.


Did you try clicking once anywhere at screen? then hover over menu or clicking menu.

Yes. Still nothing. Don’t really know what’s the cause of this issue… hmm

I think it’s would be really hard to guess without knowing the related blueprints. Though I’m not expert. You just have to show the blueprint, if it’s not personal.

maybe you have done something wrong , the better choice is to re-doing start it again ( DONT CHECK ANY BOX about INVISIBLE or something like that ) be sure the UMG is right and make the connect Level with UMG with simple Blueprint create widget - add viewports

Level Blueprint

Menu Widget Blueprint

MacGowss, did you ever find a solution to this? I’m having the same issues after converting my project from 4.13 -> 4.14.
Weird thing is that its only one widget and only in Standalone.

Ok, after bashing my head off this for a bit I fixed it.
For those of you living in the future that bump into this issue, the problem probably rests in your player controller class and involves the BP node “Set Input Mode…”

Good luck, you glorious time travelers!

@Jiyko in the future now, encountering the same problem! Would be so kind as to share what worked for you? :slight_smile:
Any input would be appreciated!
Thank you!

Sorry! I don’t even remember this issue. (don’t even remember what project I was working on when I came across this issue, It’s been a hell of a 5 years.)

ah no worries! was a long shot! thanks for the response.