"Main Menu" Widget doesn't show on Android Device

Hiya :slight_smile:
I am testing a game out that I am making for mobile devices, and I recently just added a Widget for the main menu.
The Game starts in an empty “mainmenu” level.
In the Level blueprint, I create and add the widget to the viewport.

The actual thing so far looks like this and the buttons have images for “Normal”, “Hovered” and “Pressed” inside Appearance → Style (nobody judge my awesome designing skills! <3)

and the graph for the buttons


So the issue I am running into is kinda weird, and exactly the kinda issues I hoped not to run into… Device specific stuff -_-

I tried sending a build to my phone (Samsung Galaxy Alpha) but it only shows as a white background and grey buttons. On my friends device (Samsung Galaxy S5) it seems to work just fine though…

I’ll add some images from the phones tomorrow :slight_smile:
Thank you for your time!

So I don’t really know what happened, but now the game just loads the splash screen, and then turns pitch black. The controls are still there, just invisible. I can still shoot with my right “stick” and hear the sounds, but not play the game.

Hello Beslind,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide the current OS that is running on the device?

I had the same problem once and it was a problem with the map not the widgets.

I think it was a complex material on my player character that I was using. I can’t quite remember.

Here is what I did to fix it. (Again, if I remember right. It was a long time ago.)

Try removing all your default things like player character, game state and such. Then just load the main menu map and widget. If that works, then reinstate each part one by one until you figure out what is causing it.

Hi Rudy,

I spent the last two days trying to find a way around this issue and no matter what I did, as soon as I added a static mesh in, the game would turn black screen. I scoured through the logs on my phone and found out that there was several shader errors, so I started googling this error instead, and found a guy who had a similar issue saying that it was a thing with 4.11

So I recreated the whole thing in 4.10 and it seems to work fine now :slight_smile:

Hi Parvan, thanks for the reply.
I tried your fix yesterday but that did not work. It seems the issue was with the shaders in 4.11
It works perfect in 4.10 :slight_smile:

Sir, can you pls make a tutorial for this? I too have that problem