Main Menu Problems?

Hi guys.

I have created a main menu on a separate level and it all works fine when i play it in the Viewport, i can click the buttons and they work. But when i launch my game i cant click on the buttons anymore, nothing happens. Can someone help me :smiley:

Can you show us how you made this main menu so we can try to understand where the problem is?

This is how i made it. It works fine in the viewport but when i launch it, it wont let me click anything. So frustrating ahaha :smiley:

Thanks for helpiing, when i click launch desktopalt text

Seems in order. What do you mean exactly by “when I launch it” ?

Ok, I tried replicating on my pc, and it works fine. Maybe the problem is with the buttons, can you show me how are they done?

Yeah Sure.alt text

No that dident work either :(, still no interaction from the buttons when launched.

Can you try using the OnPressed event instead of OnClicked?

I’m running out of ideas. It should work. Are you sure that OnPressed event refers to the actual buttons you are pressing (Button_32)? You can verify that in the Designer, the first row in the details panel on the right.

so have you solved your issue? can I set the last comment to answer?

Yeah its all good now. Thanks for helping :smiley:

Great to hear! :wink:

How was this solved?
Looks like i have a similar kind of a menu and the same problem…
mine looks exactly setup like in the screenshots here

In my project the menu(buttons) and its specific actions (load level/quit game) are working when i try PIE (window) and also with “Simulate” it works pretty fine.
As soon as i launch as “Standalone” and also after packaging it doesn’t work.

the menu is there, its getting loaded and i can click around, but its doing nothing somehow… not even escape key working there, have to alt-f4 to get out of the program.

are there better/other ways of getting a solid working menu implemented in ue4.14?