Main Menu level not loading

Hi I’m currently working on a fps game and I ran into a problem. At the end I have an actor trigger that creates a level complete widget. In the widget there’s a return to main menu button that has an open level bind to the main menu. However when it is pressed, the main menu map loads for a brief second and the immediately loads the level map again with disabled inputs. I don’t know what is the problem, but it used to give me an error :

TravelFailure: InvalidURL, Reason for Failure: ‘Invalid URL: /FirstPersonBP/Map/FirstPersonExample’. Shutting down PIE.
TravelFailure: ClientTravelFailure, Reason for Failure: ‘Invalid URL: /Game/Shoter/Map/MainMenuMap’. Shutting down PIE.

But it doesn’t anymore

We’ve gotta be careful with terminology here… when you say

do you mean you’re binding and event, or do you just mean the code we see here?

If it’s just the code we see here, it should work fine, unless your main menu is then immediately loading the next level…

It’s a simple on click button event, just as you see on the image. Now after some experimenting I found out that the issue is with the game mode. If I leave the default pawn as the player blueprint, the player has the same functions as in game (Moving, shooting in the void of the main menu screen). But I found out that for the main menu game mode I’m suppose to use a character as the default pawn. On the game start it works as intended (In the main menu is only menu ui and a mouse icon, and in game the player hud without the mouse icon). However again after reaching the trigger and firing the on click button event the original issue occurs.


TL;DR If I select the character blueprint as the default pawn it works but the player has game inputs and ui in main menu, and if I select character as the default pawn I have the issue stated in the above

When the game modes share the same default pawn:

Have you tried just clearing the pawn on the menu level? ( don’t specify a pawn there ).