Download

Magnified Scope

I’m curious, what is the most efficient way to simulate a magnified optic for a FPS. Currently, I’m using a scene capture component and using the RT as texture layer on the rear lens of the scope. It works well but I can definitely notice a substantial performance impact and some ghosting on my machine(I5-3750k, 16gb ram, GTX760).
Is this a common solution or am I going about the wrong way?

Thanks

ScopeView.jpg

No, that’s it really.

no scope fog, having to get dope, windage, any of the fun stuff real snipers have to do? (i was a sniper for ten years). I will say though, it looks pretty good, would make a nice acog or cco.

I’ve been trying to work this out but keep running into issues doing the final assignment to the scope mesh.
I can’t seem to find the right setup to attach the RenderTexture2d to the Mesh. I’ve tried creating it in the
event graph of the weapon as well as in the event graph of the player pawn. This was after looking closely
at the example blueprints with the Security Camera and Display screens. Everything works fine until I get to
grabbing the Texture and then trying to Create the Dynamic instance and swap it in replacing the scope mesh
face I created. I’m able to get the Texture, but finding the correct Dynamic instance setup is where I’m stuck.

Any chance you could show us how you succeeded? It would be appreciated.

Ya know what? That dang SceneCapture Object really messes with system (repsonse and that), so
I’ve gone back to a simple HUD overlay texture. Far simplier, far less resource intensive, and very easy to
implement. Working already for that matter. I never did get it to display properly on the scope mesh, but
the resultant responsiveness of the game was just too heavily impacted with it attached and active.
I was easily able to see this as my setup made the CaptureComponent InActive when not aiming and
the difference was enough to convince me it is not the best option right now.

I’m not experiencing large performance losses, but then again, my current machine is fairly beefy (i7 4770K + 32GB + 7600GT + SSD).
The setup I currently use creates the RTT in C++ using with a Blueprint callable function in a Blueprint function library.
Everything is done in the Blueprint with scene capture components that use a fairly narrow FOV.

What kind of system are you running?

Did you do it all via Blueprints or C++?

Did you limit the FOV?

I’ll see about posting a shot of the Blueprint soon.

AMD AM3+ 6core FX6300, 8GB Ram, GeForce GTX 760, running dual displays, Win7 Prem.
Original attempt was all Blueprints after linking a callback from the IsTargeting() system to activate Scope view on
certain weapons. The one thing I hadn’t gotten to was limting FoV.
On a Blank Map (empty startup map from new) and just running simulate / posess, The biggest glitch was the shimmering
affect to the weapon while moving after attaching the SceneCapture Object to skeleton. I use that empty map to test
things sometimes. I’ve got a proper outdoor map setup at 4096 / 64x64 partially setup and it was way worse.
Performance is biggest need here as I want to utilize large outdoor maps with a large number of players popping in n out.
So I don’t think I need the fancier scope style for this. Besides, I was going to move it all to c++ anyways, I was just testing in blueprints as that is really what they are best for (except some simple things).
Thinking thru it, I think I want to force them to slow down when using a scope, not going for the quick style of
Snap scope shots.

hello, I have the same problem, shadows and effects are not rendered, you solved in some way? thank you

Hi.
This is old thread, maybe to close.

I’m working with scope now, not finished yet, but some thoughts.

@**JonathanLambert **scope material should be unlit. If not, it will be affected by lighting in weapon location. If is in dark - view will be darker, if is in light - view will be lighter. Unlit solves it.
Shadows. This is problem with rendering optimization. As you can check, shadows are not rendered with high precision on large distance, meshes have own lod and simplicity. Rendering is lower generally. I think it need changes in code but you can try with changing Render Target resolution (small affect, only if current is very low, like a 256x256). Next, in SceneCaptureComponent2D you can find LOD/Detail mode. Default is low, change it to height. It can help a little, but generally, scope view will be always less detailed - mostly. Or it need custom LOD and shadows/Postproess settings for scope only.