[MacOS] Android Gradle for ARCore Error

I have done like instruction in

and install Android Support Repository Rev 47
I can package with Ant but ARcore only work with Gradle build.
But when i package it, i meet this error??

Anyone help me please!!!

UATHelper: Packaging (Android (ASTC)):
ERROR: /bin/sh failed with args -c
‘"/Volumes/Mac_Win/_ProjectGit/HandheldAR/Intermediate/Android/APK/gradle/gradlew"
:app:assembleDebug’ UATHelper:
Packaging (Android (ASTC)):
(see
/Users/nguyenthanhtung/Library/Logs/Unreal
Engine/LocalBuildLogs/UAT_Log.txt for
full exception trace) UATHelper:
Packaging (Android (ASTC)):
AutomationTool exiting with ExitCode=1
(Error_Unknown) PackagingResults:
Error: /bin/sh failed with args -c
‘"/Volumes/Mac_Win/_ProjectGit/HandheldAR/Intermediate/Android/APK/gradle/gradlew"
:app:assembleDebug’

Hi, can you attach log file?

@MrMcKvarz : Please help me, thank you so much :slight_smile:
link text

It seems some native java class fire an exception, do you use any custom java class?

I followed this tutorial and it worked, hope it helps you too.

yeah, i can build on my desktop(windows), but my macbook (macos) can’t build it :frowning:
but i can’t use pc about 2 weeks, i have to use macbook :frowning:
but sadly, it can’t build it :frowning:

Sorry, can’t help you with this, never built to android from mac.

anyway, thanks :smiley: i think it’s bug :’(

@mrMckvazr: oh i fixed it, Project needs to place on primary disk (MacOs Installed) , not external disk :smiley: