Mac studio M1 MAX 5.0.2 Freeze problem

When i open Unreal editor then got freeze
and my mac start forced reboot
Anyone help?

Same here. But instead of rebooting, it just enters in sleep mode randomly. Adding up, there’re some non persistent artifacts/glitches/flickering showing up on the UI while using the app. Sometimes it is hard to open a dropdown menu (just does not appears the first time you hover/click the parent menu item). Those may be related. And it is quite normal to freeze while clicking on a spline object (switching from node to transform gizmo mode). Got some relief by turning off realtime refresh (almost one hour without a single freeze) but the problem still persists.

I don’t think the problem will be solved quickly, so I’m just using Windows PC :frowning:

I am almost doing likewise. Such unused potential. Mac Studios are nice, but this bug is killing me! I hope it should be solved by the time the new Mac OS is launched (fully packaged with Metal 3).

5.0.3 was released but still no change.