Download

Mac - Setup.command update dependencies infinite loop.

Is anyone else seeing an issue like this? I am trying to do a build from master, but running Setup.command appears to run into a problem updating dependencies and goes into an infinite loop, never finishing and eating up gigabytes of HD space and bandwidth.

I’ve started the command, forgotten about it and then come back to this:
[video]https://drive.google.com/file/d/0B_fgPLAsJ8qyTWVPcEVRa2FqX0k/view?usp=sharing[/video]
and a 10+ GB UnrealEngine folder.

On latest OS X 10.10, latest commit on master, Xcode 6.3 etc.

Hmm… I haven’t tried to build from Master, but I built 4.7 successfully earlier this week with the same OS & Xcode versions. That means it’s either a relatively new problem, or something’s different between our setups.

You might want to do a diff between Setup.command on Master and 4.7 and see if there were changes. Might give you a clue as to where the problem is.

Wish I had a better suggestion for you.

I’m glad I’m not the only one! I ran into this problems weeks ago. I posted about it to AnswerHub but I never got a response. I eventually figured out it was an error with the localization files and figured out how to get myself into a compilable state, so I closed it. I can only assume very few people are attempting to compile the source on OSX and I hope that they fix the issue before the 4.8 preview releases.

I got the dependencies update loop issue when building master branch on Mac too last week. I thought it was my own environment issue and cant figure out the solution. Thanks for posting your solution, might try it later.