Mac OS microphone permission


Does anyone know how to enable the microphone permission for Mac?
I’m using Take Recorder and need the microphone input as the audio source.
The issue seems to be that Unreal doesn’t ask for the microphone permission.

I’ve tried the method of adding to the plist and updating the TCC.db but it still isn’t working :frowning:

Any help would be greatly appreciated!

Did you figure out the problem? I have the exact same issue. I’ve also updated TCC.db and plist. I can see “Unreal Editor” in Security and Privacy. But still the audio capture does not work in UE4 Editor.

Any of your advice would be helpful

Update: After reboot and reinstall the UE4 Editor, it is working on my macOS. Very exciting. However, I am sending 16ch audio signals through Blackhole16ch, and I just received the first two channels - stereo signals. Does anybody have ideas on how to sort/select all the 16 channels in UE4 Editor? Thanks,


Hey :slight_smile:
you should enable it via the data-protection settings.
MacOS Settings ->Data/Privacy (something like that) → Now you have a list of items, also the microphone. Enable the lock with your password and choose the microphone setting. After you be able to put the click on the ue4/ue5 banner. :v:t4:

Thanks for the answer. Yes, I did, and it is working now - receiving audio signals from my DAW. But, I am using 16 channel audio buses called “Blackhole 16ch,” and it seems like UE4/5 only received the first two channels of the audio signals. I would like to learn how to choose/use all the audio channels including 3rd to 16th in UE4/5 Editor. Thanks, JK

Hey! I’m fighting with the same issue and was wondering which .plist file did you edit.
I am launching Unreal Editor (4.27.1) via Epic Game Launcher and have updated both Launcher’s and UE4Editor Info.plist files with

	<string>Record Audio</string>

but have not managed to get Unreal Editor into the list of apps with access to the microphone.

Am I missing something else?