Mac Issues - Clicking moves the selection box up to the top of window

https://drive.google.com/file/d/0B7EsR4wlJoEmRkFxQ1Q4a0x2aXM/view?usp=sharing

The link provided shows the problem I am having with Unreal, for Mac.

I am a college student, using Unreal for my class, and I am running into this specific problem.
I addressed it to you guys a while ago, but I couldn’t reply, due to being busy at the time.

Whenever I click on anything in the interface, the selection box moves to the next thing on the list until it reaches the top.
Left clicking, Double Clicking, Right Clicking, Holding left click or right click.
If it involves clicking any part of the interface, I cannot do it.
As well, the trackpad is useless in that regard, the same problems occur to any form of mouse peripheral I use on my computer, but only to this application.

I can however, hold the sliders, and drag them. But that is relatively all I am able to do.

Without being able to click on the interface, this makes creating scripts almost completely impossible.

Because it is such a deterrent on my work, I am forced to borrow my roommate’s PC Laptop to do any of my work, or go to the local open labs.

I need to know what is going on, and what I need to do to get this working.
This is the first time this has ever happened. And this effect does not recreate itself in any other software.

I have even installed and reinstalled both 4.8 and 4.9 numerous times. This same effect still happens.

Please, if you know what to do, I would appreciate the help.

Hey Red Vanquish,

The best way for me to help you with your issue, is to first get the specifications of the computer you are using to see if there are any compatibility issues.

Are there settings on your Mac you are changing about the mouse interaction within applications?

Thanks,

Andrew Hurley

Here are the specs for my laptop.

Macbook Pro (Early 2013, Retina, 15-Inch)
Memory: 16 GB 1600 MHz DDR3
Processor: 2.7 GHz Intel Core i7
Graphics: NVIDIA GeForce GT 650M 1024 MB

Since I recently installed Unreal, It has all the default preferences. I have not changed anything.

I should have clarified a bit more. Have you messed with any mouse settings on your Macs system preferences/settings at all?

Also, not that it should make a huge difference, but are you using the trackpad or an actual mouse?

Thank you for providing me with your requested information. I am going to continue to investigate this issue. If you find any new or relevant information on this issue, that you might have left out please let me know.

Thank you,

Andrew Hurley

I have not made any dramatic changes to the mouse or trackpad settings, other than turning on most of the Trackpad Touch gestures.

As for what I used:
I have used both the trackpad, a standard Gaming Mouse, and a standard windows mouse.

It does the same thing as what you are seeing here.

After reading your reply, I wanted to see if changing my settings on my mouse and trackpad would do anything; so I turned off all of my Trackpad’s Touch gestures and for the mouse, changed the double click speed to a low setting. After which, I opened Unreal and tested it again, Unfortunately the same outcome occurs.

Hey Red,

Thanks for testing my theories about the mouse options on your Mac. There were issues like this reported with earlier versions of the Engine on Macs, but not many reports have been made since the past few iterations of the engine.

This issue is quite interesting as there have been some known reports for this to occur to users, but at a very small scale.

  • Do you have any sort of external devices plugged in that could be causing the interface conflict?
  • Any applications running in the background that could be causing this to occur?

Let me know if you have questions or discover any new information.

Thanks,

Andrew

The only other application that opens, which I have tested by closing, is the Epic Games Launcher.

And any external devices being only the USB Mouse. Which I have also unplugged and tested with the trackpad.

What OS X version are you running?

At the time, it was the Mavericks OS.

Now I have El Capitan, and the same problems persist.

Note: I do not think that it is a problem with my OS.

Unfortunately, unless I have some evidence of this occurring I cannot generate a bug report. Could you possibly provide a video of your issue? This would be enough to create a bug report and at least get eyes on the issue.

Thanks,

Andrew Hurley

I placed a link in the post, the moment the discussion was generated, on October 13, 2015 at 8:32 PM.

Please look at the top post, for the hyperlink listed above.

Here is the link, just in case.

https://drive.google.com/file/d/0B7EsR4wlJoEmRkFxQ1Q4a0x2aXM/view?usp=sharing

I set the video as fully public, so it should be available for you to see.

Thank you for the video. Since this is not occurring on my end, could you test to see if this issue occurs in either 4.9.2 or 4.10 engine versions?

If it no longer occurs in a future engine version, then entering a bug is not necessary.

Thank you,

Andrew Hurley

Having trouble finding topics about this, as i am having same issue, but with current unreal. Running imac 21.5 w i7 os high sierra
I have this issue roughly 95 percent of the time and its severely limiting progress.

Ok found a workaround on os sierra…in system preferences under mission control, set it to group application windows