Mac - 4.4.0 install - error: No such file or directory

Hey all,

So, I’ve just recently installed UE4 on my Mac and immediately ran in an issue when I was win the Community Portal. I went to the Library section, which by the way immediately started showing what seemed to be an infinite loading bar, and I then clicked the install button on the 4.4.0 build under the Engine Slots heading. All that did was cause it to queue the task, and the infinite loading bar remained. If I click the “x” button to cancel the queued task, it brings up the confirmation dialogue, but then does nothing when I click yes. If I close and re-open, the task then can be re-queued, but still infinite loads.

I followed a fix for a Mac from another post: Link To Post.

That didn’t work. So I took a look at the log files and when GetDiskFreeSpace( ) is called, it returns and error of “statfs failed with code 2 (No such file or directory)”. I can’t seem to find a fix here in the AnswersHUB.

I’ve included the zip with my system info and logs: UE4_Logs

Thanks a bunch,

So… I almost found a work-around and thought I’d share it. I opened the terminal and ran the executable as root.


As soon as I did this and logged in (I had to re-enter my credentials), It began installing the latest build immediately (4.4.0), with a successful verification at the end of the install. When I went to launch the toolset, I ran into another issue:

Afterwards, I closed the Community Portal, re-opened it the normal/typical way by clicking on the .app icon, and it went back to the bug, but this time it said “Resuming” on the 4.4.0 install, instead of it being queued:


That the statfs call is failing with that error is interesting - can you make sure that there is a /Users/Shared/UnrealEngine/4.4 folder? If the creation of that folder has failed then that would explain your problem. You certainly have enough free space on your boot drive. Probably best to install and run the launcher from the main drive too, not leave it on the read-only disk image.

As an aside you are running on an Nvidia Geforce 8800 GT which is not supported as it is well below the minimum specifications and does not support the necessary rendering features for UE4, hence the pink rendering. You may be able to get the editor to work if you build from source, but as of 4.4 it won’t work. We know about this bug and will look at it for a future release if time permits.

Hey ,

The 4.4 folder exists, along with a “Launcher” folder. I feel for some reason when I run it as a regular user, it thinks it doesn’t have permissions for something… that’s why it errors out and shows that infinite load. I’ve got UE4 running at home though (on PC), so that’s good enough for now. I just wanted to tool around with it in my spare time at work, but since it’s a weaker computer it seems that wont work out.

Anyways, if you want me to do anything else that may help pin-point the bug, just let me know.

I know what this is now - if you go into /Users/Shared & select the ‘UnrealEngine’ folder in Finder. Then open the File menu and select Get Info. At the bottom there is a Sharing & Permissions section, expand it and ensure that you cane read & write. If not, click the tiny padlock icon & enter an admin user name & password. Then select Read & Write for each entry in the table. Then click on the fancy star/gear like icon just next to the minus button, and select Apply to enclosed items… in the drop down menu. This will correct the permissions so that the launcher can install the engine.