Download

Luoshuang's GPULightmass

They are all set so to get the most out of it, haven’t had this on while i was baking on CPU.
Regarding to those fireflies, what worked for me to get rid of where the Sunlight directly hits was to set the FireflyClampingThreshold to 10.
Eventhough i ve got weird splotches around the whole scene. The scene also went a lot darker :frowning:

Have you tried to turn OFF “Use Ambient Occlusion” in World Settings?

Does “Generate Ambient Occlusion Material Mask” in the World Settings do anything while using GPU Lightmass? Because I’m intending to use the Precomputed AO Mask node in my material but it doesn’t work.

Edit: Just read it’s not supported. Any chance to get it in the future?

Script updated to detect 4.22.1 CPU. It is really not important thou and a minor update, as the GPU kernel remains the same.

Hello, looks like it doesn’t recognise my UE4 version
“Unreal Engine Version 4.22 not installed or registry not set”
How con I resolve that? Thanks

Is that possible to get rid of this area shadow of skylight? I would like that my skylight distributes better the light…

Yep…is currently set to OFF, its not taking it into account.
BTW: Does any of these settings in the World Settings matter with this GPU Approach?

Would anyone know why this gets stuck for me on a RTX 2070 Max-Q machine, but works fine on a GTX 1060?

Here’s some detail: I run the same project and lightmass setup, but when I run the light builder, everything seems to work fine up until it finishes the radiosity cache. Then, it just sits there. No modal errors, nothing in the output log, it just sits at “Overall texel progress 0.00%”.

From a task manager standpoint, when the build is first started, it crunches away as expected - the CPU utilization pegs high, and cuda cores peg 100%. Then, as soon as the radiosity cache is done (10 passes) the CPU settles down to 20%, and then 0% on cuda. I’ve left it like this for hours. The “Building Lighting: 0%” never changes, nor does the “Current batch 0.76% Block 1/132” and “Overall texel progress 0.00%” in the GPU Lightmass progress window.

Things I’ve tried:

  • TDRLevel is set to 300
  • Cleared the SwarmAgent cache
  • Rolled back to try two different sets of drivers on the RTX 2070
  • Last ditch effort: just mass deleting elements from the project and re-testing until light building works; which it never did

Using 4.20.2 of Loushuang’s with a project that is set up in 4.20.3.

The system it works on with the GTX 1060 has the same amount of system RAM (32GB). The 1060 has 6GB of GPU memory, while the 2070 has 8GB. I’m convinced it’s a 2070 thing, and possibly something to do with the Max-Q architecture. ¯_(ツ)_/¯

You should change “lower hemisphere color”… Make it more brighter. If you use hdri for skylight, you can disable it.

Yes the Indirect lighting Bounces and the Num Sky Lighting bounces

Hi,
Any info to fix this error?

16:59:46: GPULightmass Kernel: Importing mesh: 94746496 vertices, 104756177 triangles
17:00:30: GPULightmass Kernel: Embree SBVH Construction finished, 43179MS
17:01:10: GPULightmass Kernel: Convert to CudaBVH finished, 40695MS
17:01:14: GPULightmass Kernel: Line 86: cudaCheckError: out of memory

I’m using a 2080Ti, i7-9700k and 32GB of ram

Thank you

Hi all. In the same way as many other UE4 users, I have found this tool a bit late. Unfortunately I am following the steps that Luoshuang poses, but I can not install the GPULightmass engine from the source. The version I have of UE4 is 4.22.1, it jumps an error that says: "GPULightmasKernel.dll is missing. Some of you can tell me the steps to perform the correct installation. I am not a video game programmer, I am an architect in love with the tool that UE4 gives me.

Did anybody have the opportunity to test 2080 ti or maybe 1080ti vs 2080ti in GPU Lightmass?

Worked! Thx!

GPULightmasKernel.dll <---- Looks like a misspelling in your Lightmass.ccp. GPULightMasSKernel.dll - Missing one S.

I have been getting a strange bug where certain faces usually facing in one direction in both positive and negative render completely back. all of a sudden it started happening on meshes I haven’t touched or changed anything on. I have tried what seems like everything, I have re uv’d, changed lightmap res, and countless other things. in one section i have had luck with just simply exporting and re importing while changing nothing and it has fixed the issue. In other areas that fix dosent seem to work. Ill post some images in lit, unlit, and lighitng only.
Its the horizontal beam above the ceiling.

Thanks in advanced,

Well, you’ll need to know how to compile the engine from source if you are using this version to install. Have you built the engine successfully from Source code using Visual Studio 2017? Make sure when you’re building, you follow instructions on what to edit along with SceneExport.h here: Luoshuang's GPULightmass - Unreal Engine Forums

I’d advise using the Binary version instead of Source. Are you modifying the engine source code? It’s usually not necessary unless you’re doing a lot of engine code edits. I presume you’re not since you said you’re not a game programmer. Stick with Binary and use Situx’s script.

2080TI it work smooth in 4.22

Still having this error, here are some more images. i tried migrating the level to a fresh project and it fixed some but introduced others. I also tried using cpu lightmass and im getting similar unpredictable errors.
I am at a loss, I dont understand why all of a sudden these meshes started acting like this and I just cant figure out a fix or why its happening.

Is there a way to use more than 1 local gpu? Can I run an example using four gtx1070 at the same time?