Lumen GI and Reflections feedback thread

Thanks for the reply. Sounds logical - will dive into VSM to find a solution


Hello, Please look into this issue and provide a possible solution for this, Thanks!

Last I checked, mesh cards are generated strictly upon import scale and parameters, meaning no matter how big you make the object in world space, if it doesn’t fit the minimum size necessary to receive cards, it won’t have any coverage. The only real solution you have is to import a mesh big enough to receive coverage.

1 Like

i might wanna add: mesh distance fields play a lil role too. flat, thin or too small objects will not generate voxels either to fall back on.

(i’m slowly digginng into the lumen code. bit of an odd state right now. i wanted to check if i can fix the sample fog. volume tracing is in active progress, tho. hmm…)

Isn’t it possible to rescale/transform an object and then sort of “bake-in” the new transformation and force the new object to acquire cards for lumen again ?

Yeah. Only one addition: I think I remember something like if you enable in the static mesh the option Emissive Light Source, it would be included in the Lumen scene. Not sure, but @Error can try.

That is a good point you raise, but I don’t believe it will solve @Error’s problem. AFAIK, the Emissive Light Source tag forces the surface cache to not cull a given mesh’s cards, to stop emissive objects’ lighting from popping as the camera gets closer or further away. However, it can only stop the surface cache from culling cards if the mesh had cards to begin with, and if an object is too small to have cards it won’t be in the consideration at all.

Oh, I see @jblackwell ! Anyway, your post was the answer.

PS: Hi @Krzysztof.N , not sure if I mentioned this time ago (I don’t remember any reply), but hair under GI (no direct lighting hit), is quite terrible:

To reproduce: download the Meerkat demo. Take the Meerkat BP and place it into any new map with a floor and a ceiling. Check the scary result turning the camera around the meerkat.


Thanks for the comment, I have tried this, but the card has no update.

yeah, But to understand the minimum size requirement for lumen, is there any intel? Which help me to understand the way lumen think, this model will receive card coverage and other will not - I mean just to set the boundary on clear technical terms!

Thanks for the comment, I’ve checked these point and here are the results.

Mesh Distance Field is good here? They have generated for all objects with enough resolution to cover the shape.

Btw Global distance field have ignored all slats models including other small models which have been used in the scene! Does this mean which models is not covered in Global distance, tend to represent yellow in Lumen scene? They are looking true to me! Any details information on how to include these tiny details into Global distance field will be crucial and i would like to test more on to this!


I wonder if you might be better off using nanite displacement or WPO offset or something to get the slats to have coverage but still have actual depth.


I have not used nanite in the project and also disabled using the following commands! There is no improvement on the coverage!

r.Nanite.ProjectEnabled = false
r.Nanite = 0

I’ve followed the mention process in the link here!

You could consider using a proxy mesh that is only visible in raytracing, with simpler / slightly different geometry that can be more easily covered by lumen. It is quite normal to use proxy geometry or lower LoDs with raytracing so this approach is not unusual.


Thanks for the information. This idea looks promising, I will check the setup and post the results.

Hi guys,

Just upgraded to 5.4 and tried increasing the number of refraction bounces for lumen to increase visuals, but noticed that the interiors turn darker and dont let in much GI from the outside. I checked it in the viewmodes and I see that if I increase the refraction bounces, the windows (thin translucent glass) turn black in the lumen scene. Is it expected or is it a bug? Any way to get back that good fill lighting from the outside?

Thanks in advance.

Afer trying to make and failing a mirror in my bathroom for 1 month, I decided to make it with Scene Capture Cube and Render Target but I have a problem with this. Finally I created an mirror that its reflecting but the illumination or enviroment lighting is not matching with my real-time interior. Am I missing something?

I found this video and tried to do everything same but the result is…

‘’ ‘’

Hi guys,

I am not sure if it is Lumen related, but I have found this feature called “ManyLights” in the 5.4 engine, which greatly improves the performance when enabled. But I see some strange artifacts on the screen, when enabling it. It seems to me that it happens when too many lights are overlapping AND the total illumination from these lights is too large. If I decrease the light intensity or reduce the exposure or the number of overlapping lights, it seems to be gone. Do you guys know about this problem?

1 Like

To determine if it is lumen related, the simplest option would be to disable lumen and see if the artifact goes away.
Try doing the same with virtual shadow maps.

1 Like