Download

Low poly textures/shaders when play launcher?

When i edit my game or play the game on ‘‘launcher’’ or the ‘‘Play’’ button the textures/shaders are not loaded well. Many objects have low poly textures, the problem seems to be a bug in the system. When the launcher is played textures are fading in sharp sometimes, and pop back to low quality and after that back to high, low, ertcetera. And for many textures like grass they stay low poly.

See pictures below for thesame ingame experience where textures/shaders change from low to high within seconds, and again back to low quality. What is going on here? When i start the launcher UE4 is not compilling anymore, not building shaders as it normally does.

http://s4.postimg.org/xqxldic9p/swapp.png

http://s4.postimg.org/as0vulg9p/swappinggg.png

low poly error on launcher
http://s29.postimg.org/d17c8pz37/low_poly_launcher.jpg

better quality when play in editor
http://s3.postimg.org/syoicppfz/play_button.jpg

It seems my shaders are not compiling and processed anymore, when i drop an material on a mesh it just shows a low poly texture. UE4 has stopped compiling shaders, stopped processing and building the whole shaders. Does someone know why?

Thanks for the one that is sharing his or her knowledge!

Try changing your Engine Scalability Settings or Material Quality Settings

I looked into it and all the settings Engine Scalability and Material quality are allready on the highest settings. See the link for more info about these settings:

The problem is that UE4 is not compilling data anymore, it is not building shaders anymore, mayby that is the problem. Can i do this somehow manually?

Low resolution textures*** Sorry. Had too.

The problem seems to be a huge bug in the system. When the launcher is played textures are fading in sharp sometimes, and pop back to low quality and after that back to high, low - ertcetera. And for many textures like grass they stay low poly.

It’s an issue with mipping/texture streaming.
If you set the texture to don’t use mi mapping it will be working fine, but that’s not efficient. I’ve also had this problem for a long time I hope it gets some more attention.

If it is not too bad for the performance i can live with that. How do i find that option? And yes i had this issue before too but for some reasson it came back.

It’s not OK for performance, but it doesn’t mean it’d kill it either. It depends on your project.

Frpm texture group select NoMipMaps

Also the NoMipmaps does not seem to work for every texture. I started a new project, and also in there the problem shows up. It looks like a huge bug in UE4 again…

Again an example, look at this grass in ingame. The grass is supposed to be high quality grass, but instead it is extremly low poly and not loaded. If someone from Epic could look at this? I don’t know anymore where to look or what to do.

http://s22.postimg.org/hndbvlx8x/ingame.png

Strange thing is that the problem is not happening in official UE4 demo’s but it is when starting a new project or open an existing project of myself.

I ran into this problem using the Substance plugin. When that plugin was active almost every texture that was not compiled in substance as a sbsar would do this. I was able to stop it from happening by checking Never Stream in the texture settings, though I think that may do something similar or the same thing as NoMipmaps, so I’m assuming it’s not great on performance.

With the same textures in another version of UE4 NOT using the substance plugin, I would still see this issue once in a while but it was very rare and usually stopped when I hit play in editor.