Download

Low FPS in a empty scene with a High end laptop

Hey there I hope you can help me my Unreal Editor runs at low fps. If I made a new level in a empty scene so I just see the black screen and the grid I just got arround 40 fps. And when I start something like the effect cave I just get around 16-25 fps. Do you have any tips for me.
Here are my specs:
Alienware M18x r2
8x Intel(R) Core™ i7-3610QM CPU @ 2.30GHz
2x Nvidia Geforce GTX 675m
16gb ram

Tested with high settings in viewport.

Howdy SPfaff1994,

If you have not already, could you please also post this issue on our AnswerHub. Here is a link: https://answers.unrealengine.com/index.html. Also, could you please use the “How to report a bug?” template so that we may better assist you with the issue that you having. Here is a link for that post: How do I report a bug? - UE4 AnswerHub

Thanks and have a great day!

Most gaming laptops have a power save mode (NVidia has Optimus). It could be that this setting is turned off, which would mean the game is running on the integrated graphics chip.

Are you plugged in? I know in my laptop with dual nvidia cards, if I’m not plugged it, only one card gets used.

I would definitely check the power settings - if it’s like most laptops it’s set to use less power/prefer power saving over performance when unplugged, as Darren and Acenth mention. If it’s got an integrated card, it might also have a specific switch and/or you can add your UE4 exes to your GPU control panel and tell it to always use your dedicated card for those programs.

I tried some of the tips and the funny thing I find out is if I’m in a empty scene I have about 40 fps now and if I open the elemental demo in high I also have around 40 fps

Go to nVidia control panel and add application profile for UE4 binary with high-performance videocard set.

So I go to nvidia control panel than mange 3d setting and add UE4 there right ? Did I have to change something in the settings ?

This. I don’t have dual cards, but if I am unplugged my performance goes to the *******. Make sure you are plugged in and are on high performance mode.

First off, don’t start on high settings, on my laptop i usually start at medium and make sure things load nicely before moving on.

Second, I have an ATIV book 8, and if yours is like mine it may have 2 GPU options. One using a local intel one for power saving, and another (your 2 intels) for performance. I actually have to use my laptops specific drivers to choose which ones get used on every application. If you have this, make sure it gets set for your GeForces.

Finally, a problem I discovered with my laptop that’s specific to if you are using the Source version of the engine and building it yourself… MAKE SURE when you load the project in to Visual Studio that you let it IDLE for about 5 minutes before you build. This means AFTER it has loaded all the files. Because I discovered that when I opened the project, it would load additional files in the bottom left corner awhile… then stop. But AFTER it stopped for a minute or two, it starts again adding ADDITIONAL files! UE4 is a HUGE project and sometimes it takes visual studio awhile to process what’s going on. And if I compiled the project before it added every single file, it would actually work okay when I launched it, but have HORRID performance as you describe. After I realized I need to let it sit for awhile before compiling, performance improved and now its great.

So the most important things for my PC - Personalize your Power Settings to make sure it’s on max performance, Check your laptop specific video card drivers to make sure you are using your GeForces, and if you are building the engine yourself ensure you give ample amounts of time between loading the project and compiling.

Good luck!