Low FPS - Gf 970m

Didn’t think I would ever have the need to post in regard to something like this, but after a week, I’m at a loss or im determined that my GPU must be failing in some weird way maybe. I’ve been using UE4 for about a year now and have learned so, so much. My project is going really well, and of course I have run into FPS issues before, however, always related to overtaxing content, or something running in the background etc.

This week however, after launching the project, I run a fine 60FPS 'with Smooth Frame enabled". After about 5-15 seconds, it will drop to about 30-35fps. I can make jump back to 60, if I lose focus to the editor and poke around the menus, or open another window in front and then go back to the editor. During profiling, I notice everything goes up, Draw, Game, GPU and Frame. So, i figured my project became broken somehow. I started a new 3rd person project. Same thing. I then started a new blank project…same thing. I then started another blank project, and deleted every single asset…same thing. SO with rendering nothing…i only get 35fps, and it bouncing around 30-35. Changing the visual resolution and specs from epic, to medium or lower, same thing.

So, I then update my GPU drivers, same thing. I wipe my computer clean, and reload windows 10 x64, update all drivers and bios, same thing. I then went back to original GPU drivers, same thing…

I am at a total loss here. I’ve done additional GPU profiling with the frame capture, but of course pretty much everything in the red are items i just don’t understand. If sending any profiling data to anyone that may be able to help out, im all for it. Otherwise, I’m guessing my Alienware is just hitting the bricks after 2 years, and time for a replacement…?? idk.

My specs are as follows:

Alienware R3 17
Intel 6700HQ 2.6 - 3.2Boost
nVidia 970m

It may be related to this : Low FPS in editor on high end PC - Asset Creation - Epic Developer Community Forums

Does it drop to ~30 fps forever or only for a moment? It may be auto-saving or doing something that temporarily caps it to 30 FPS. I also would recommend turning off “Use less CPU when in background” from Edit->Editor Preferences->General->Performance

That was an excellent call - i actually read that thread also after I posted this and so I uninstalled the geforce experience entirely. Things I thought were looking good, but unfortunately no. It starts at a solid 60 and then dips down. Once it dips down, it does seems to stay down. I also disabled the less CPU in background, but unfortunately same issue.

Maybe its not even my GPU that the issue, since everything rises (draw, game, gpu, frame), and its the CPU. I have my power settings to best performance (since the 1709 WIn10 update, there is a slider now in place of the power profiles).

I think my next try will be to let Windows install the GPU driver and remove the nVidia manually installed driver.

Yet, I can play games, run 3dmax - as far as I know, everything else runs just fine…its so bizarre

Do you have GPU-Z? You should monitor both CPU usage and GPU usage and see if there’s a change when the framerate drops

I was hoping it would be the geforce thing, because clearly your system can handle running it (albeit for 10 seconds).

Since it’s a laptop, the GPU may be throttling from a higher temperature. The temps are low for the first 10 seconds but then get too hot (according to settings). One test I can say for that is to run something like Furmark for at least 1 minute, to heat it up, and then fire up UE4 as quick as you can (with your project) and see if it has the 60 FPS at all. If it’s throttling from the heat, then it should be pre-throttled from Furmark and you should never see 60 FPS

To clarify, check the CPU+GPU usages when it’s running at 60FPS for a few seconds, then look again to see if either one drops

The 5-15 second range may be the heat. Maybe if you let it cool down you can get 15 seconds before it heats up too much, and when it’s only 5 seconds maybe it’s not cooled down enough

Well here it is…if you don’t mind giving away 8 minutes of your life staring at numbers increasing & decreasing lol. I swear it continues to get more and more bizarre. I tried my best to keep the HW Monitor in-shot while trying different screen modes of UE4. This is using the Windows installed driver, which may have helped a little…but its just weird.

For whatever reason, this time it took probably almost a full minute before the frame rate fell.

At one point, you can see when I move the mouse over to the right side assets list, it made the frame rate drop.

Video of FPS Drop

Okay heres what i think is going on.

Your GPU usage was decent when it was 60fps, and the temps were totally fine
As soon as the GPU hit about 60, the usage shot to 100% and the fps dropped.

It looks like your GPU is throttling around 60C (it absolutely shouldnt), which causes the clock speed to drop. Because of the clock speed drop, the usage shot to 100% and the FPS dropped

Can you use Afterburner or some software to see the clock speed of the GPU?

Do the same thing you did in the video (just move around and watch)
But when the fps drops see what the GPU clock is

Hopefully this is the issue and its something we can get fixed. That looks very frustrating

Yep, I notice that as well, so I download the GPUz program afterwards, but it doesn’t seem like its throttling at all - I will still toss up another video just in case i’m missing something.

One thing I made the mistake of doing, is after wiping the machine clean, I should have installed only the required drivers, UE4 and then tested. I had Chrome, 3dMax, substance design & painter, adobe creative cloud suite and I think that’s about it, other than Webroot AV, which I also disabled to check, with no effect unfortunately. I think I will wipe and reload again tomorrow, to give that a shot in seeing if there is some piece of software running that doing it.

Thanks a bunch for putting the time into this for me - I think I’m past the frustration part, and now its just became depressing, however, i’ll try and switch my state of mind to realize that at least I can still develop for the most part, but profiling just wont be a thing for now…I mean even developing will be tricky seeing as I wont really know if something is truly taxing the system too much or not, but just trying to think positively about the situation somehow haha.

Thanks again

Believe to have found the “problem”. For the first time I moved UE4 over to my second monitor which is only a 1080p monitor, and my FPS went up to 60 for the first time in a long time. My laptop screen is a 4k screen, however I always used like 70% or lower resolution in the graphic settings along with the viewport settings at the default resolution of 1280x720 - not realizing this only takes effect when you play the level in a separate window and the 70% thinking that was enough to dub it down to near 1080 res or at least enough to run it smoothly.

My only guess as to why it was smooth before and then wasn’t anymore, UE4 by default, I believe turns the settings down if it detects low FPS after x-amount of time…I must have reset those settings back to ‘Epic-Settings’ and disabled the auto-manager at some point - that’s the only thing that makes sense to me.

I hope this might help someone else out there that might be running into a similiar hiccup.

My only other thought is, I wonder if there is a way to view the actual resolution that is being rendered?

Thank you again for those who put some of their own time into looking at this and giving ideas. Very much appreciated and I too, in return, will take some time to go through and answer some questions for others in need.

What is interesting if that’s the problem, is why would you get 60fps for a few seconds?

I know it may not be the best suggestion, but in Windows you can change your laptop resolution to 1080p and then adjust the scaling so it looks native (and so your cursor isn’t 1 pixel hahaha)

Then UE4 will be using 1080p on your laptop screen and if 4K was the cause then the issue should be fixed and you should get a solid 60fps again

That is another excellent point there AJ…I wish I had some sort of explanation…

Funny you mention the windows res because I did try that as well, and I believe I still had the same issue - Also, I know how to scale up but being able to scale down in windows, using the display properties percentage, that I’m not actually aware of?

EDIT: I think i found it - There is windows advanced scaling settings. I’m going to try this method again
now and see if it does in fact give the same results or not.

Well, that also is giving me 60FPS now - however, i’m just so baffled as too what you mentioned with getting 60FPS temporarily, and also the fact that when rendering no landscape or assets, while still get the low 30FPS with the native 4k res…

Must still be an underlying issue going on, maybe it was a recent windows patch, UE4 and nVidia graphics driver all fighting and overall causing the GPU to stress for nothing.