Looking down slows movement speed.

I understand why it does this I just dont know how to fix it. All of my components get rotated with the camera so when I face the ground the forward vector faces the ground aswell. This slows my movement. How would I go about fixing it?

By default the capsule doesn’t inherit pitch, so it’s probably not rotating when you look down. meaning the forward vector is always flat forward.

You could see it for yourself by playing in editor, looking down, pressing f8 to unpossess and looking at the capsule. You’ll see it’s straight up.

No idea why your character would slow down when looking down.

Interesting.

After checking the capsule seems to be rotating. How can i prevent this? @Evigmae

Select Class Defaults on your character blueprint

265985-0.png

and on the details panel, on the pawn section, make sure “inherit pitch” is false.

265986-1.png

is your character a custom pawn, or did does it inherit from character?

It inherits from the character. The problem with this is that with this disabled the mesh now does not move with the camera. Let me fiddle around a bit more though. @Evigmae

Hey there, you ever figure this out?

I think the right way will be to pass “Actor forward vector” instead of “Capsule forward vector”, though I don’t understand why it’s not working.