Download

Long saving time in Material Editor

Hi !

Is there any setting in the engine or system that can cause that saving material in material editor takes 2-3 min ? All the rest of the functions works smoothly (importing meshes, saving blueprints and material instances) It’s happening in both - full game and - blank projects. I tried some online solutions like testing if any app in background is causing this - no luck.

My PC spec:

AMD Ryzen 5
Nvidia RTX 2070
G.SKILL F4 DDR4 3000 C16 4x8GB

I’m lost in the dark here - I will be grateful for any suggestion. Thanks!

Hey, this is not that uncommon, as all the shader permutations get compiled when you save the material (and there is quite a lot of them by default).

Take a peek here, if you haven’t disabled any of the “Shader permutation” options before, you will definitely see an improvement, the other stuff is more experimental, but can also help.

https://medium.com/@lordned/unreal-e…s-2b975e503dd4

And within each shader, check the “Usage” tab of the settings and only select the usages you actually need with the given material.

But even after disabling all the “Shader permutation” options and some other optimizations, ~20 seconds is pretty much the fastest I’ve ever gotten on save.

Also make sure you make use of material instancing so you don’t have an unnecesary number of the same shader sitting around.

Thanks ! I will definitely check it out.