Download

Logitech steering wheel plugin

Compatible version: 4.6.0
Last Update: 3rd January 2015

Plugin - The plugin for Unreal Engine 4 itself, including source code. Copy contents of the archive to your project folder.
MyWheelLib- source code of static library exposing the steering wheel functionality

The plugin was created to be a BP interface. If you want to use the plugin from code, you can get the instance using IG27Plugin::Get() method and then call functions manually.

All nodes are visible in Input > G27 Plugin

http://www.infiniteproduction.eu/images/uploaded/wheel_setup.jpg

Needs to be called at start of application. You can also call this directly from StartupModule(), but this will break Play-in-Editor mode.

http://www.infiniteproduction.eu/images/uploaded/wheel_tick.jpg

It’s doesn’t matter where you place the Tick, it needs to be called every frame.

Our vehicle controlling blueprint that will maintain compatibility will classic input axis when wheel is not connected.

http://www.infiniteproduction.eu/images/uploaded/wheel_usage.jpg

This plugin was created as part of a client VR project, where we needed to use steering wheel (Logitech G25 and G27) for maximum immersion. This version is what we used during the event, it’s pretty simple, but does the job.

The plugin is split into 2 parts - the plugin itself and MyWheelLib, which is a C++ static library exposing steering wheel related functions, using Logitech SDK as base.

While i would like to continue working on the plugin and i have pretty huge to-do list, I’m not sure when i can find time to actually do it. So please accept this quite unfinished plugin as a gift, if you need anything more you’ll need to write it yourself. And if you do, please consider sharing it.

I have a weird problem with the camera attached to the car in the vehicle template. The camera won’t rotate with the car when I steer the car left or right. The camera isn’t in the correct position inside the car. How can I fix the problem? I need a version of the plugin for UE 4.7.3.

Hello, seems pretty unlikely it’s caused by the plugin, as the plugin is just read interface for wheel. I’m using it with 4.7.3 and it works just fine. When you disable or remove the plugin, does the problem go away? If not, try looking at the camera setting or camera manager.

I tried to use the plugin with 4.7.3 and I got the following images:

g27plugin1.PNG

g27plugin2.PNG

How can I fix the problem?

Reuploaded the plugin compiled with 4.7.3. But it’s going to break again with new version, more stable solution is to use code project and compile the plugin yourself everytime UE4 gets an update. Even Express or Community edition of Visual Studio will do the job.

How do I use the code project and compile the plugin?

The G27 plugin for UE 4.7.3 works! You need to add the Wheel Tick node between the Event Tick and Sequence nodes.

I’ve re-made this plugin into something more complete, using the current version of the Logi SDK. It now supports blueprint programmability for force feedback effects (you can even use curve assets to control various parameters etc). Also, all axes and buttons are now present as inputs (under Game Controller) for input mapping as well as events in blueprints.

Here’s the project source: https://bitbucket.org/whiten01se/logitechg27plugin. Enjoy.

One thing is worth noting: I didn’t bother to implement a Win32 path for this plugin, but you can do that yourself if you really need 32bit support.

I am having a strange issue. I cannot find the WheelTick or Activate Wheel nodes in the blueprint editor.

Anything for the wheel is searchable by entering “G27”. There are axis events for the wheel (the WheelTick doesn’t exist anymore), but you can also utilize the normal Tick event to just grab the value via Get Wheel Axis value. The ActivateWheel method is gone too, and replaced with SetProperties, which basically does what ActivateWheel did, except less crash prone. The wheel is always active during an editor session. I did not quite manage to cater for temporary availability (unpluggin/reconnecting) yet. Perhaps someone else has a good idea how to properly do this…

Another hint: If you try to build/package from the editor, you might run into a linking problem, because Logitech chose to use ATL in their SDK, so you will have to add


PublicAdditionalLibraries.Add("atls.lib");

to the build.cs file of the plugin.

Hey thanks for plugin but when i try to lunch project it says following modules are missing or built with a different engine version: UE4Editor-LogitechG277Pugin.dll … (i tried Engine version 4.76 and 4.8)

i m not a programmer could you help me how to solve this problem.

@Superdolgu - I get that when trying on a launcher build, but not on a source build.

Unfortunately, even on source build, the plugin doesn’t work. Blueprint nodes are their, but they don’t return anything besides zero.

Could somebody that has it working post a whole example project?

I have the same issue as BlackRang666 & Superdolgu. Has anyone worked out the solution?

Correct me if I’m wrong, but since this thread originally refers to the G27 Plugin, I assume that there has been no traction because it’s now an outdated piece of hardware.
So, since the current selection from Logitech is the “G920 Driving Force RACING WHEEL FOR Xbox One AND PC” has anyone out there had any success with it on a more recent version of the Unreal Engine (UE 4.12 or so)?
Cheers,
-JZed

Is there anything up to date to use a steering wheel in ue4?

Hi, I have working plugin for version 4.17, I skipped 4.18 and didn’t try to compile for that version
I would like to make update for 4.19 but I am getting some errors I can’t solve on my own

Maybe this read someone who can help in solving those errors so we can have working plugin for 4.19

1>C:\Program Files (x86)\Windows Kits\8.1\include\um\securitybaseapi.h(472): warning C4668: ‘_APISET_SECURITYBASE_VER’ is not defined as a preprocessor macro, replacing with ‘0’ for ‘#if/#elif
1>C:\Program Files (x86)\Windows Kits\8.1\include\um\securitybaseapi.h(1302): warning C4668: ‘_APISET_SECURITYBASE_VER’ is not defined as a preprocessor macro, replacing with ‘0’ for ‘#if/#elif
1>C:\Program Files (x86)\Windows Kits\8.1\include\um\winbase.h(8618): warning C4668: ‘NTDDI_WIN7SP1’ is not defined as a preprocessor macro, replacing with ‘0’ for ‘#if/#elif
1>C:\Program Files (x86)\Windows Kits\8.1\include\um\dinput.h: DIRECTINPUT_VERSION undefined. Defaulting to version 0x0800
1>e:\unreal projects 2\pluginmaker_4_19\plugins\logitechwheelplugin\source\logitechwheelplugin\private\LogitechWheelInputDevice.h(55): error C4596: ‘SendButtonUpEvent’: illegal qualified name in member declaration
1>e:\unreal projects 2\pluginmaker_4_19\plugins\logitechwheelplugin\source\logitechwheelplugin\private\LogitechWheelInputDevice.h(56): error C4596: ‘SendButtonDownEvent’: illegal qualified name in member declaration
1>e:\unreal projects 2\pluginmaker_4_19\plugins\logitechwheelplugin\source\logitechwheelplugin\private\LogitechWheelInputDevice.h(57): error C4596: ‘SendAxisEvent’: illegal qualified name in member declaration
1>UnrealBuildTool : error : UBT ERROR: Failed to produce item: E:\Unreal Projects 2\PluginMaker_4_19\Plugins\LogitechWheelPlugin\Binaries\Win64\UE4Editor-LogitechWheelPlugin.dll
1>Total build time: 116,08 seconds (Local executor: 0,00 seconds)
1>g:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command ““g:\Program Files\Epic Games\UE_4.19\Engine\Build\BatchFiles\Build.bat” PluginMaker_4_19Editor Win64 Development “E:\Unreal Projects 2\PluginMaker_4_19\PluginMaker_4_19.uproject” -WaitMutex -FromMsBuild” exited with code 5. Please verify that you have sufficient rights to run this command.
1>Done building project “PluginMaker_4_19.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Thanks in advance