Download

Lods > 0 are not displayed in tiled landscape from heightmap import

I imported a tiled landscape from a heightmap. When I generated e.g. Lod1 for a landscape tile, it is not displayed. Only Lod0 is displayed, regardless of my distance to the landscape tile. Is there some setting that i missed?

What are the terrain’s LOD settings? Can you post a screenshot or two?

Thanks for answering!
Here are all lod settings i could find. Hopefully this is what you meant?

World settings lod:

Landscape Lod Settings:

example settings of one tile, where I set lod mesh percentage to 1.

Is this what you asked for?

Relarive distance 10 is likely the problem.
leave it at default and test it out.

Also, force lod 3 with landscape export lod (because its the best not too heavy LOD)
And set the reduction-static mesh details perce tage- to half (.5) then generate.

See what you get. They work for me, and they transition correctly too.

The mesh LOD percentage is set to 1 under LOD1 (after Tile settings, under LODSettings). Doesn’t that result in requiring the screen size of a mesh (component in landscape) to be 100%? If you check, even in the mesh editor, a screen size of 100% is about half the actual screen width / height. The Max LOD setting is -1 (the 2nd screenshot of settings, or when selecting the landscape), which means it renders the highest LOD available, which is LOD 0. So, if it’s not rendering a tile at LOD 1, and always rendering LOD 0, then it’s always rendering the highest LOD of 0. Try changing the Max LOD to 2 or at least 1, but preferably higher. Then, if it’s 2 or 3, the Max LOD rendered would be 2 or 3, not 0, and 1 could potentially be rendered in the virtual texture.

‘Lowest’ LOD is 0, and is the highest resolution
‘Highest’ LOD is the maximum number in all LOD levels (so 6 in the RVT), and is the lowest resolution (unless specifically modified to be a better resolution than other LODs)

LOD 0 should be streamed in at close distances, and higher LODs streamed in at further distances, sequentially from 0 to X (X being maximum LOD level). Lower resolution at further distances to increase render speed / reduce memory usage.

If the Max LOD change to 1 or higher doesn’t fix it, there’s probably an issue with how the LODs are set to render with the view distance. Some settings aren’t correctly set, or haven’t gotten set yet.

[USER=“3140864”]MostHost LA[/USER] If i set relative distance to 10.000 or less or more, there is no difference. Always Lod0 is displayed.
What do you mean by “force lod 3 with landscape export lod”? I set it to half, still Lod0 is displayed :frowning:

@presto423 I set LOD percentage to such an extreme value because I wanted to see if anything changes, it does not. even if i change it to 20/50/70%
I set the max lod setting to 5, still no difference.

I noticed that, when in editor view, I can set the Lod to Fixed at LOD7 for example and then the mesh is really triangles are really reduced. So it seems as if Lods are automatically generated, but that i cannot change the LODs myself, which I need.

A little background: I have imported a 6x6km heightmap area with 24cm/px using import tiled landscape. I divided the landscape to 2048x2048px big tiles. I only ever want to display a maximum of 2x2 tiles with Lod 0, every other tile with a lod of almost no triangles, even a plane with a texture would be enough for the distant tiles.

Look. after the process is over the engine produces a mesh with materials.
Open up the mesh. check what the LOD settings ON the actual mesh are.
You can manipulate them and change the distance like any other LOD.

The panel in question is only used to Generate the mesh. Those are the settings that allow for that.

I haven’t worked with or learned about tiled landscapes before, so I was coming from the perspective of using components to generate a landscape and if the LOD settings in the landscape actor details panel could show something about the problem by changing it or solve it. I was actually testing a scene with a large landscape, I think larger than yours, and I was having a different issue that was interfering with my testing…so I’m sorry I couldn’t help. Perhaps look on youtube for a video about tiled landscapes in UE4, and creating LODs.

By default, tiled worlds do not include anything past a distance of something like 5000 or 5000.
for obvious reasons. Even at LOD9 the landscape still retains nearly all of its vertices causing a massive overload of tris count.

The impostors solve that by taking whats there (which is why i suggest starting of from lod3 and reducing from there) and simplifying based on angular percentages so that a mesh with 1000000 vertex ends up having maybe half.

The impostors are then streamed in as replacements based on the distance specified by the level, however the internal LODs are subsequently handled like everything else based on Size On Screen.
you can balance them manually one by one - as well as actually verify they were produced with appropriate level of LODs.