Download

LOD elements issue

Hi all,

I imported a ship (20 different objects skinned on the same bone hierarchy) as a skeletal mesh in Unreal Engine 4, i’m trying to use LODs on 3 objects among 20. I didn’t face any issue when i imported the base LOD (i got 4 elements in skeletal mesh editing mode which is matching the amount of materials applied in the ship in 3dsmax before .fbx export), but when i tried to import the LOD1, i got 10 elements instead of 4.

1.gif

I don’t understand because the LOD1 meshes selection in 3dsmax has the 4 same materials applied. Is there any name convention for each group in 3ds max ?

For instance :

LOD0 : lod0_object1, lod0_object2 … lod0_object19, lod0_object20 ?
LOD1 : lod1_object1, lod1_object2 … lod1_object19, lod1_object20 ?

Could you tell me please what is causing the issue ?
Thanks

Edit:

I forgot to tell you that in 3dsmax, 3 materials are applied in the same object and one material is applied to 19 different objects.

Please help

I haven’t been able to get naming conventions to work when importing to UE4. I don’t think it understands it currently.
In 3ds max you have to setup LOD groups for each object before importing to UE4.

I have the same problem.
Though mine is a regular static mesh with 2 materials exported from Maya. It imports correctly with two material elements but when I import it’s lods I suddenly have 9 elements - sometimes 11 elements or more. I have tried exporting a lod group from maya and also importing the lods individually as fbxs. Same problem.
I have also deleted history.

Did you find a solution OP?

I am having same issue with basic downloads of fbx with 4 types of meshes and materials into unreal, I feel you there the name convention is for you or your team. http://www.tomlooman.com/ue4-naming-convention/ It is possible to rename but your gonna want to do that way before you build a library of chaos. Keep it simple and there are no rules but what you can remember.

Thanks, but I don’t think using a naming convention after the fact is going to solve this problem. This is happening somewhere between exporting and importing meshes with lods. Superfluous elements are being created somehow.

Have you tried renaming totally wierd to see where they are goin? I had same issue 2 yrs ago when I found it was under the progect file. sorry wish I was more help

Yep, I’ve exported the fbx using a different name and into a fresh ue4 project also but the problem persists.

I had the problem a while ago as well and deleting history in Maya fixed it…but I wasn’t using lods at the time. it’s a weird one.