LOD bug 4.7.2

Setting up a LOD (skeletal mesh) is bugged, works at first then stop working when i hit play, to make it work again i have to close and re-open the project, hitting play will make it stop working again (stuck on LOD1)

Can re-create the issue at every attempts

Updated to 4.7.3 and the issue is persisting, also if it can help, i only have two LODs (LOD0 - LOD1), LOD1 was imported through the skeletal mesh edit window (LOD settings → LOD import)

Another observation, i am absolutely unable to remove the bugged LOD1, by choosing to re-import the mesh the LOD1 still exist, i haven’t tried to completely delete it from the project as i’m sure it would cause some issues with my blueprints and references

I decided to make a new project and it worked, i don’t understand why it doesn’t want to work in my existing project, any ideas?

Hey KhenaB,

Thanks for the update. I just got around to being able to test this and was not able to see the same results. I’m not sure what would be causing the existing project to behave incorrectly, but if the problem is to come back please let me know and I can look into this further.

Thank you!


I’m not sure what to say, the problem can’t come back since it was never solved, i just need to figure out why LOD glitches in my project, i have no idea what could be causing this and what i could try to do to solve it

I understand that this is complicated for anyone to say without looking at the project but i just don’t know what to look for, should i just migrate all my assets to a new project?

I finally managed to figure out what was causing this

sg.ViewDistanceQuality was set to 0

Guys I’m having the same problem here :stuck_out_tongue:
My skeletal mesh’s LOD is always LOD1 or higher… LOD0 is never showing.
Not to mention that setting the Screen Size seems to have little to no effect… it’s definitely not working as well as static mesh LOD, that’s for sure.
Using fresh 4.7.5 project and sg.ViewDistanceQuality = 1 doesn’t seem to have helped either.

EDIT: nvm… just make sure the view distance under scalability settings is Far or Epic or set sg.ViewDistanceQuality = 2 (or higher)