Download

"Lock viewport to Actor" missing in UE 4.8.0

I can not find “lock viewport to actor” in the viewport dropdown, I have googled around and found a couple of questions without answers.
Has this feature been removed/moved to another place ?

I was looking into this same problem and found that if you right-click the object/actor, there is now an option to ‘Pilot’ it.

Hi everyone,

You can create a shortcut in the editor preferences>Keyboard Shortcuts to snap view to object, which allows you to lock the viewport to actor as you have described here. This is also available as aecastaneda mentioned, in the right mouse button context menu.

So, the feature was completely removed then? Compared to the “Pilot” option that feel really, really awkward (and had a big circle in the middle of the screen representing the color), it seemed that the previous setting enabled free camera movement that was the same as the viewport.

The documents should be updated at some point to reflect that change.

Thanks for bringing this to our attention. While we are constantly working to keep the documentation up to date, I’ve added the following report to prioritize this page being updated: [UEDOC-2129]. When it is corrected, I’ll add an update here.

thanks for the answer people

The documentation has been changed to describe how to “Pilot Actors in the Viewport” which allows you to lock the Viewport camera to a given actor.

Piloting actors can sometimes mess up the rotation of the viewport. Locking to actors didn’t have this problem!

select the object/actor,and press ctrl+shift+p to do it.or u can right click this obj ,select “pilot ‘obj name’”.
选中目标物体,然后按下快捷键ctrl+shift+p来实现这个功能.或者你可以右键这个物体,然后点击pilot “物体名称”.

Same here. I prefer the ‘Lock Viewport to Actor’ controls. The Pilot Actor can be cumbersome and time consuming.

Thanks. This worked just fine.