Lock Actor Movement Bug

When using “Transform->Lock Actor Movement” on a Landscape actor, the setting does not persists after exiting the map. Meaning, on opening the level again, the landscape is no longer locked.

Lock actor movement works on other actors and persists on level exit, but the landscapes don’t.

I’m using 4.4.0 Github engine. I also downloaded launcher 4.5 version, downloaded a new VehicleGame and verified the same problem for repro.


Hi ,

Does this happen in a clean, blank project with no additional content or is it limited to the vehicle templates?

Hi thanks for the reply,

the bug happened on our project, so i just downloaded the vehiclegame for repro confirmation. After I saw it was the same there, I didn’t continue other test scenarios.

Can you show me a screenshot of how you are drawing the lock actor movement? I have not been able to access this node. Landscape actors do not traditionally have a movement option and therefore have no movement to lock.

Sure, I have attached the screenshot. You can lock the movement in 2 ways. If you right click the landscape actor in the scene outliner, it will be under the Transform option. Secondly, if you right click the landscape on the viewport the same menu item shows.

This option works perfectly when you turn it on. The problem is that when you leave the level and come back, it didn’t save the state. Its unchecked. On the other actors, I’ve tested, it stays on when coming back. Therefore, it seems unique to the landscape actor.

Let me know if you need anything, else!

This feature is very useful for the level design process as the map gets passed around to other people for work. We’ve experienced accidental landscape moves when one person was placing models, so we lock out the actor movement to prevent these accidents. However, recently we found that it was not actually saving the option on reload.

Hi ,

Ah I see what you mean now, I had misunderstood what you were attempting to do! I was able to reproduce this and have entered a bug report, TTP#349738 to be assessed by the development team. Thank you!

Thanks ! Glad to help :wink:

Same bug, it happend when you select multiple objec ton the map with alt+ctrl and then it unlock the landscape