Localization doesn't work

Hello, I’m working on localization for now but any text is not tranlated as current culture.
I ran commandlet to generate localization manifest and for each archives, which was successful.
Above data can be verified by opening each archive file and translation editor in unreal (experimental feature included at 4.1).

I tested it by below code. TEST_NSLOCTEXT is included in archives for both “en” and “es”. and I set their translated value as “TEST_EN_TRANSLATED” and “TEST_ES_TRANSLATED”.

GEngine->AddOnScreenDebugMessage(-1, 100.f, FColor::Red, TestHUDText.ToString());

I ran the game as DebugGame from VS(set command parameter as “-game -culture=en”), play mode in editor, play stand alone through editor(set additional parameter to “-culture=en” as well), and play mobile simulator. All tests show the same result: display TEST_NSLOCTEXT on the screen by red…

How can I fix them…? I can’t find any further solution… please help me…

References I found,


Have you regenerated the localization resource files (*.locres) after having modified the archives? The loc res files are the actual binary files that the runtime loads for translations. The manifest and archives are used to generate the loc res files.

It works after upgrading unreal to 4.6. It seems to be bug at 4.5.1. I don’t know why it is fixed.

thanks anyway :slight_smile: