Download

Local Wifi Multiplayer without using Google Play?

Hi all,

I am working on a Gear VR app for the mobile game jam. I was hoping to be able to use simple local wifi multiplayer, since that’s what was suggested by Oculus. It sounds like getting Google Play support requires you to publish your app on Google Play, which I don’t want to do, or get everyone’s Google Play username, which I can’t do.

I set up my project according to the Multiplayer shootout example. It works OK on the computer in Play in Editor mode. However, once loaded onto the phone, I get this error message when I run the Create Session blueprint node:



LogScript:Warning: CreateSession - Invalid or uninitialized OnlineSubsystem
LogScript:Warning: CreateSession - Cannot map local player to unique net ID


I have the following permissions set in Project settings:



android.permission.INTERNET
android.permission.ACCESS_NETWORK_STATE


and in my DefaultEngine.ini I have:



[OnlineSubsystem]
DefaultPlatformService=Null


So just to update the curious — Google Play does not work either, as currently sessions are unsupported.

The first error about Invalid or uninitialized OnlineSubsystem can be fixed by adding OnlineSubsystemNull to the Build.cs file. However it only gets as far as creating and joining a session, server map travel is broken.

Currently the only OnlineSubSystem that is officially supported is Google Play and that does not have complete support. Google Play will not play nice with the Gear VR however, because it requires the user to access various 2D overlays. So the user would have to switch their phone into developer mode.

In the meanwhile you can connect directly over the LAN with the console command ‘open IP_ADDRESS’, which you can access with a four-finger tap in developer mode before putting the phone into the headset.

I know this isn’t a answer like you wanted but I have knowticed every one is a bit hesitant to allow anything VR go though there lines, if you have any luck with getting a service to allow you to use there wifi/multiplayer functions for a mobile device concerning VR functions I would love to know.

Are you saying the sessions work on android via LAN(wifi)? Should I wright exacly “OnlineSubsystemNull” and where, just at bottem?

So, this is the only thread I’ve been able to find on Android Multiplayer over wifi.

I had been having trouble getting multiplayer to work between a PC and android device. After a lot of trial and error I’ve found that it is possible a PC host and an Android Client.

However, I’ve yet to get it to work with a GearVR Android app.

Has anyone confirmed if this does/doesn’t work. And if not what the issue is?

Thanks

Swifty

Hi guys

Same with me the only thread I’ve been able to find on Android Multiplayer over wifi, i made a small android project that run perfect in pc as host and join but when i put it in android the Clint can’t find the server so the session search and join fail .

i use direct WiFi to connect both device together ,and my blueprint is create and search then join session ,and i am new to the engine so anyone succeeded to make a game run on android Multiplayer over wifi ? if yes then how ? hope we get your answer as i reached to the desperate point for the last week that i am searching without any luck .

any help guys ?

Any help guys from epic team maybe ?

thumb up! I’m interested too

i just tested the same project by connecting the client to the server by command and putting the IP and it worked in the same phone so why its not working with search and join session ,so pls anyone know where is the problem ?

I have same problem too about connecting two phone over WiFi , it’s a little tricky.
I just test the simple 3rd person project with create, find and join sessions nodes… But join not working! Session created and other phones found it but couldn’t join! I couldn’t find any answer, But open IP address was working

thumb up!
there is nothing about Wifi android on the forum except this .

Can we get any tips from Unreal team ?

I am still interested in this, can’t find anything. Any help would be great.

Psychogony,

Your PR #1820 was accepted for 4.12 today :slight_smile:

Awesome - Thanks Chris (and thanks in general for the forum attentiveness/responsiveness, its often your name on the answer I am after).

I just tried this issue on the 4.12 p4 and it’s still happening on my end. Have a server on android, can connect via direct ip, but find sessions does not find my android device. Is it only working on the source version of the engine?

As I am currently in the development stages right now on a cross-platform game with built in DLC… I need this function to work for downloading the content from a host (or the play store). I do NOT want my customers to be able to download the DLC using their cell data (must be connected to wifi).

As there are several settings on the devices that detect if it’s on wifi or not, this should be reasonable to implement within the engine for us blueprinters.

Is this fixed?

Edit: I’ve read that indeed it’s fixed in 4.12 and some people confirmed it so I’ll reformulate the question.

Does this mean that I can finally make use of the Google Play Game Services Real-Time Multiplayer functionality and finally make people play each other through Internet just like Steam?