Local multiplayer input always affects player 1

Hi. I have been searching for answers on this, poking around, and even following tutorials and I always seem to have the same problem even when the tutorials I watch don’t have this problem.

I have a local multiplayer project in UE 4.22. It is a shared screen multiplayer game. I have all of the players spawning correctly. I can even move Player 1 around using the gamepad. The problem occurs when I try to move Players 2, 3, and 4. Players 2, 3, and 4 all move fine expect for the left thumbstick y-axis. Whenever I try to move Players 2, 3, or 4 using the left thumbstick y-axis, Player 1 also moves in the same direction at the same rate, but only player 1 has this problem. I have not changed the way the input works. I am using the third person example character movement.

At first I thought it might be a bug in 4.22 but I tried it in 4.21 and experienced the same problem. Has anyone had this problem before?

You will need to post images of your setup in order for anyone to be of assistance. Hard to give advice when we cant see what is happening in your code or BP.

Here are the pictures of my setup. I managed to try a different type of gamepad (xbox one) and it worked fine. And upon farther testing, it looks like its both of the thumbsticks that have the problem in both axis, too. But the problem only occurs with the xbox 360 gamepads as far as I can tell.

Just a thought - check which characters are possessed by the controller, or in the settings for the character if they are auto possessed.

After more searching about Xbox 360 gamepads, it seems sometimes the drivers get mixed up and have trouble recognizing more than 1 gamepad at a time. I uninstalled the devices,unplugged all the controllers, restarted my machine, and plugged them back in one at a time waiting for the driver to finish setting up before plugging in the next one. It is working perfectly now.