"Loading Visual Studio" takes forever eventually opens with no solution - compilation not possible

Just getting into some Unreal C++ tutorials. First step in most is to create a C++ Class and then open it in Visual Studio 2017. If I click to open the new C++ class I made in the Unreal Engine first a command prompt opens in the 2017/BuildTools folder. Then the “Loading Visual Studio” notification sits for about 5 minutes. I checked the task manager, nothing is happening. It then opens with no solution, but it does open the class files. Compiling is not linked to Unreal when this happens.

If I manually open the VS solution and hit compile with UE open things work as I would expect. Any ideas?

This happens with any project. I downloaded the Action RPG project to play with. It runs fine. Hit “Generate Visual Studio project” and go to open one of the C++ classes in the Content Browser. 5-10minutes later VS opens with no solution and only the one file. Compilation is not possible.

Any idea? I’ve tried “Reset Visual Studio”.

Switched to Visual Studio 2019. Problem solved. Opens instantly, everything functions as expected.

Clearly something is wrong with my VS 2017 install/settings but I don’t care enough to find out what.