Loading Visual Studio 2017 toast doesn't disappear

This only happens when Editor Preferences > Source Code > Source Editor setting is set to “Visual Studio 2017”. As long as the toast is visible I can’t double click on any C++ classes to open up the files in the open or closed editor.

Switching it to “Visual Studio” makes the toast disappear again and somewhat inconsistently opens up a new instance of 2017 or uses the current instance, it will also open up all the attempted double clicks at once.

LogWindows: LaunchFileInExternalEditor F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.h 
LogWindows: Launch application code for F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.h : 42
LogWindows: LaunchFileInExternalEditor F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.cpp 
LogWindows: Launch application code for F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.cpp : 42
LogVSAccessor:Warning: Couldn't access Visual Studio
LogVSAccessor:Warning: Couldn't access module table
LogVSAccessor:Warning: Couldn't access module table
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.h'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.cpp'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.h'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/Grabber.cpp'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/PositionReporter.h'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/PositionReporter.cpp'
LogVSAccessor:Warning: Visual Studio is open but could not be queried - it may be blocked by a modal operation
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/OpenDoor.h'
LogVSAccessor:Warning: Couldn't goto line number '0' in 'F:/Dev/UnrealCourse/C03_BuildingEscape/BuildingEscape/Source/BuildingEscape/OpenDoor.cpp'

I have the exact same issue with version 4.17.1. I’ve just uninstalled Visual Studio 2017, uninstalled Unreal Engine 4.17.1, ran the Visual Studio Total Uninstaller (GitHub - microsoft/VisualStudioUninstaller: Visual Studio Uninstallation sometimes can be unreliable and often leave out a lot of unwanted artifacts. Visual Studio Uninstaller is designed to thoroughly and reliably remove these unwanted artifacts. ), then reinstalled the whole lot.

Starting a Basic Code C++ project in Unreal, I let the project load in Unreal Editor and Visual Studio, before closing Visual Studio. I set the Source Code Editor to “Visual Studio 2017” from “Visual Studio”, then create a new C++ blank class. Visual Studio opens, although the toast saying “Loading Visual Studio 2017” in the Unreal Editor will remain on screen indefinitely. Leaving the Source Code Editor set to “Visual Studio” will make the toast function correctly when attempting to open the class from the Unreal Editor, however it creates a couple of warnings…

LogVSAccessor: Warning: Couldn't goto line number '0' in '.../Documents/Unreal Projects/MyProject/Source/MyProject/MyCharacter.h'
LogVSAccessor: Warning: Couldn't goto line number '0' in '.../Documents/Unreal Projects/MyProject/Source/MyProject/MyCharacter.cpp'

I haven’t done the re-installs but, I’m in the exact same boat. These warnings are very scary though as they suggest the Editor can’t find the source code.

Also, the link on your “Visual Studio Total Uninstaller” is dead for me. Not sure why.

I have the same issue, que only difference is that it loads 2015 instead of 2017.

Hey Everyone,

While I also saw the “Loading” message remain on screen in 4.16, I found that the message does disappear in the 4.18 preview when VS2017 is set and a new class is added. Let me know i you run into this in the latest preview?


I just got 4.18 and I’m having this issue. I didn’t have this issue in 4.17.

I Have this problem too ( VS 2017 and UE 4.18.0

Though this didn’t appear in the preview, we did noticed the message remaining on screen after the 4.18.0 release as well. This has been reported here for investigation: Unreal Engine Issues and Bug Tracker (UE-51608)

Expanding on this, the behaviour outlined in UE-51608 also occurs when opening existing classes, and isn’t exclusive to creating a new class. It also only happens when the Source Code Editor is set to “Visual Studio”. If it’s set to “Visual Studio 2017”, then the toast doesn’t ever seem to disappear (I waited 15 minutes), but the files do immediately open and focus in Visual Studio, and a second instance of Visual Studio doesn’t open. This is with VS2017, UE4.18, and using a brand new 4.18 project.

I’m having the same issue using VS2015 after upgrading to UE 4.18, tried going back to 4.14 and now it’s doing the same thing after having no problems earlier today before I even installed 4.18. Tons of different errors across the board (such as opening multiple instances of VS and each instance colliding with the next), but this is by far the scariest. I don’t want to continue writing code for fear of the compiler not finding it somewhere down the line.

Sorry to double comment, but now it doesn’t seem like UE and Visual Studio are working in conjunction with one another anymore. Everything has been completely broken since I “upgraded” and I’m considering switching engines (can’t completely halt production, after all). After reading all possible Answers I could on this topic, I have realized that this has been a severe issue for months with no apparent fix on the horizon. I was loving UE4.14 and wish I had never even touched it. I’m very disheartened to say that I am completely disappointed by the lack of (or more, turtle-slow) support/care for this issue.

Edit: I’m going to try reverting Visual Studio 2015 Update 3 back to Update 2 and see if that fixes it. If not, the only thing I can think of is to try out VS2017, but I’ve that brings on a whole nother host of issues. Will report back with my results.

Edit2: So many different attempts at this and I think I got it working.
Sorry for my cranky post, I was scheduled for a biopsy today, plus my livelihood depends on this engine working. Now that I’m back from the doctor, I had a little bit more of a clear mind to finally figure it out. Going to rest now, but I will come back and post step-by-step what I did to get UE4 functioning as intended! Sorry for the wait, but if you want to take a crack at it, it involved a fresh install of VS2017, deleting Intermediate Saved and Binary folders (copy them off somewhere else & create system restore before making changes!), giving admin privileges to both UE4 and VS, and rebuilding/regenerating everything. That’s as much as I have in me for now, but I will retrace my exact steps when I come back to this post. Ben the instructor’s answer at this link "Could not be compiled. Try rebuilding from source manually." - #3 by VytautasR - Ask - GameDev.tv was a good guideline and helped fix most of my major synchronization issues (haven’t tested the minor ones yet e.g. the original toast problem; will report back)

Triple comment, my bad…

Edit2 continued: I also changed the editor preferences to VS2017 after the install, but you guys probably already know that.

Update: Okay, I have a little bit of fight left in me to test the toast issue (these issues have kept me awake over 24 hours). Currently 30 min & toast still hasn’t vanished. Will update if it changes within another half hour.

If anyone reading this is also affected by this issue, please vote at Unreal Engine Issues and Bug Tracker (UE-51608) so it can go up the bug priority list!

A little helpful workflow tip from Gamzie1 on reddit for “coping with” some of these 4.18 bugs:

It’s only happened since 4.18 - I’ve
just coped with it tbh. My way of
working when I get to my is open
the vs project first and launch the
debug editor target with ctrl + F5
(launches without attaching debugger)
then I make sure this is the instance
of VS I use. Every time it opens a new
process for VS I just close it (the
one unreal opened) down. it sticks
saying “opening VS” in the bottom
right hand corner of the editor for a
little while but does eventually go


Update 2: It has now been an hour and a half and the toast label is still stuck on “Loading…”
Shutting it down and going to bed.

Update 3: Now that I’m up, getting all sorts of errors all over again. Every time I clean, rebuild from vs, or generate new files after using methods in my above post it’s a new error. .dll can’t be found, fix it, then .pdb can’t be found, fix it, now vcxproj can’t be found, it’s an endless cycle. If not that, then it’s permissions denied here, or can’t find ue4.exe (upon debugging from vs) there… I’ve never had this much trouble with an engine.

After many re-installs of Unreal Engine 4.18.2 and visual studio 2017. With the UE editor and Visual Studio open at the same time, I’ve had the Source Code Editor set to Visual Studio 2017 in Edit > Editor Preferences in UE. I’ve set it back to the 1st option ‘Visual Studio’ no version mentioned and now it properly keeps in sync only one VS instance open no matter how many classes i add in UE.
I’ve also had VS 2015 installed, after uninstalling it, it broke some libraries for VS 2017 needed for c++ projects including UE. So make sure you check Windows 8.1 SDK for example when checking c++ development modules in VS modify installer and anything else that might make sense to include for c++, best of luck !

This issue (at least, when creating a new class) UE-51608 has been fixed for version 4.19.
When opening a class this also happens, but no idea if this is also fixed too.

I’ve dowloaded 4.19 now to see if it solves the problem. But nothing changed. First it was alright, but now after restarting UE once, this problem is still there. The only way to get rid of this message, is to start the .sln manually from the Unreal Projects folder before opening any c++ class via UE. Then its alright, no matter how often you open and close c++ classes.

I have 4.19.1 and still show Loading Visual Studio 2017

also 4.20


Changing “Source Code Editor” from Visual Studio 2017 to just “Visual Studio” fixed it for me too.

Running Unreal Engine as administrator fixed for me

Create a shortcut for Unreal Engine in your desktop.

Right click > Properties > Advanced > Check 'Run as administrator'

  • Make sure to have VS C++ for Games, MFC libraries, Unreal installer installed on your Visual Studio installation.